Bug 835338 - Review Request: eclipse-wtp-jst-web - Eclipse tools for working with JavaServer Pages (JSP)
Review Request: eclipse-wtp-jst-web - Eclipse tools for working with JavaServ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 837726
  Show dependency treegraph
 
Reported: 2012-06-25 23:07 EDT by Gerard Ryan
Modified: 2012-08-01 14:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 14:26:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mgoldman: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2012-06-25 23:07:18 EDT
Spec URL: http://galileo.fedorapeople.org/eclipse-wtp-jst-web/3.4.0/0.1.RC4/eclipse-wtp-jst-web.spec
SRPM URL: http://galileo.fedorapeople.org/eclipse-wtp-jst-web/3.4.0/0.1.RC4/eclipse-wtp-jst-web-3.4.0-0.1.RC4.fc17.src.rpm
Description: Eclipse tools for working with JavaServer Pages (JSP).
Fedora Account System Username: galileo
Comment 1 Marek Goldmann 2012-07-05 06:14:39 EDT
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

=== REQUIRED ITEMS ===
[!]  Rpmlint output:

SPECS/eclipse-wtp-jst-web.spec: W: invalid-url Source0: eclipse-wtp-jst-web-R3.4.0.tar.xz
0 packages and 1 specfiles checked; 0 errors, 1 warnings.
eclipse-wtp-jst-web.src: W: invalid-url Source0: eclipse-wtp-jst-web-R3.4.0.tar.xz
1 packages and 0 specfiles checked; 0 errors, 1 warnings.
eclipse-wtp-jst-web.noarch: W: file-not-utf8 /usr/share/doc/eclipse-wtp-jst-web-3.4.0/LICENSE.txt
eclipse-wtp-jst-web.noarch: W: file-not-utf8 /usr/share/doc/eclipse-wtp-jst-web-3.4.0/CDDLv1.0.txt
1 packages and 0 specfiles checked; 0 errors, 2 warnings.

[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[!]  Package successfully compiles and builds into binary rpms.

Build fails, see #2.

[x]  Buildroot definition is not present
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[x]  License field in the package spec file matches the actual license.
License type: EPL and CDDL
[x]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[-]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[x]  Sources used to build the package matches the upstream source, as provided in the spec URL.
MD5SUM this package    : 1f579a783b532438bdf7152977e3875b
MD5SUM upstream package: 303d2c91b9471bfd03ab07bbbc176e42

CVS export, ok.

[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates or must require other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  File sections do not contain %defattr(-,root,root,-) unless changed with good reason
[x]  Permissions on files are set properly.
[x]  Package does NOT have a %clean section which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT). (not needed anymore)
[x]  Package consistently uses macros (no %{buildroot} and $RPM_BUILD_ROOT mixing)
[x]  Package contains code, or permissable content.
[x]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[-]  Javadoc documentation files are generated and included in -javadoc subpackage
[-]  Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlinks)
[-]  Packages have proper BuildRequires/Requires on jpackage-utils
[-]  Javadoc subpackages have Require: jpackage-utils
[x]  Package uses %global not %define
[!]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)

See issue #1

[x]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.
[x]  Jar files are installed to %{_javadir}/%{name}.jar (see [6] for details)
[-]  If package contains pom.xml files install it (including depmaps) even when building with ant
[-]  pom files has correct add_maven_depmap

=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.
[x]  Reviewer should test that the package builds in mock.
Tested on:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4219449

=== Issues ===
1. Add info how to generate the tarball.
2. Build fails: http://koji.fedoraproject.org/koji/taskinfo?taskID=4219450

=== Final Notes ===
1. Please fix the utf warning on the license files (iconv?)
2. Source1:  fetch-%{name}-using-map.sh is not necessary, remove it.
3. Btw, there is a typo informing that the script that creates the tarball names it X.tar.gz, but in fact it's X.tar.xz.
Comment 2 Gerard Ryan 2012-07-05 12:47:32 EDT
Spec URL: http://galileo.fedorapeople.org/eclipse-wtp-jst-web/3.4.0/0.2.RC4/eclipse-wtp-jst-web.spec
SRPM URL: http://galileo.fedorapeople.org/eclipse-wtp-jst-web/3.4.0/0.2.RC4/eclipse-wtp-jst-web-3.4.0-0.2.RC4.fc17.src.rpm

=== Issues ===
1. Add info how to generate the tarball.
DONE

2. Build fails: http://koji.fedoraproject.org/koji/taskinfo?taskID=4219450
DONE - http://koji.fedoraproject.org/koji/taskinfo?taskID=4220305
- I don't know why it wasn't building for you


=== Final Notes ===
1. Please fix the utf warning on the license files (iconv?)
DONE

2. Source1:  fetch-%{name}-using-map.sh is not necessary, remove it.
DONE

3. Btw, there is a typo informing that the script that creates the tarball names it X.tar.gz, but in fact it's X.tar.xz.
DONE

Thanks! :)
Comment 3 Marek Goldmann 2012-07-06 02:42:55 EDT
Awesome, thank you!

================
*** APPROVED ***
================
Comment 4 Gerard Ryan 2012-07-06 08:02:50 EDT
New Package SCM Request
=======================
Package Name: eclipse-wtp-jst-web
Short Description: Eclipse tools for working with JavaServer Pages (JSP)
Owners: galileo
Branches: f17
InitialCC:
Comment 5 Gwyn Ciesla 2012-07-06 09:15:33 EDT
Git done (by process-git-requests).
Comment 6 Fedora Update System 2012-07-06 11:30:47 EDT
eclipse-wtp-jst-web-3.4.0-0.2.RC4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-wtp-jst-web-3.4.0-0.2.RC4.fc17
Comment 7 Fedora Update System 2012-07-06 17:26:27 EDT
eclipse-wtp-jst-web-3.4.0-0.2.RC4.fc17 has been pushed to the Fedora 17 testing repository.
Comment 8 Fedora Update System 2012-07-13 16:11:27 EDT
eclipse-wtp-jst-web-3.4.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-wtp-jst-web-3.4.0-1.fc17
Comment 9 Fedora Update System 2012-08-01 14:26:55 EDT
eclipse-wtp-jst-web-3.4.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.