Bug 835388 - Erratic boot behaviour after updating a fresh installation
Erratic boot behaviour after updating a fresh installation
Status: CLOSED DUPLICATE of bug 830432
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 02:08 EDT by Sean McKinley
Modified: 2012-06-26 14:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 14:54:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (64.12 KB, text/x-log)
2012-06-26 02:08 EDT, Sean McKinley
no flags Details

  None (edit)
Description Sean McKinley 2012-06-26 02:08:14 EDT
Created attachment 594357 [details]
dmesg output

Description of problem: I installed Fedora 17 from a live cd and then proceeded to update the system. The system intermittently fails to boot (most of the time) or boots correctly. Falling back to the original kernel (3.3.4-5) causes the system to boot correctly 100% of the time.


Version-Release number of selected component (if applicable): 3.4.3-1


How reproducible: Just turn on/restart the computer.

  
Actual results:

A number of different things have happened so far, which I will now try to enumerate in a semi-coherent manner. The behaviour begins after the computer indicates it is loading the initial ramdisk. Numbers 1a and 2a occur most often, 1a and 2b rarely, 3 only twice and I can't seem to get it to come up again, 4 only once, and 5 once in a while.

1a. The monitor turns blank (but remains turned on) and the computer does nothing. This requires a hard reboot.

1b. The monitor turns blank (but remains turned on) and the computer does nothing. The computer restarts by itself.

2a. The monitor turns off (but goes into standby) and the computer does nothing. This requires a hard reboot.

2b. The monitor turns off (but goes into standby) and the computer does nothing. The computer restarts by itself.

3. Kernel panic. I wrote down the following warnings from amidst the sea of text:

"Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b"
"BUG: unable to handle kernel paging request at fffffffffffffff8"
"Fixing recursive fault but reboot is needed."

4. Once this warning repeated itself:

"Soft lockup: CPU#3 stuck for 23s!"

5. The system boots properly. 


Expected results:

The system boots properly 100% of the time.


Additional info: The system boots properly 100% of the time when the 3.3.4-5 kernel is selected from the GRUB2 menu. I tried removing rhgb from the boot options and that did not work. There was also nothing in the System Log Viewer from the times I unsuccessfully tried to boot.
Comment 1 Sean McKinley 2012-06-26 14:54:57 EDT
I've received several new errors while trying to boot this morning.

1. [FAILED] Failed to start Remount Root and Kernel File Systems. See 'systemctl status systemd-remount-fs.service' for details.

2. Kernel BUG at mm/slub.c:3474!

This led me to Bug 830432 where I noticed several similarities (same chipset, difficulty booting, and nouveau driver). Installing the proprietary nvidia driver seems to resolve the problem.

*** This bug has been marked as a duplicate of bug 830432 ***

Note You need to log in before you can comment on or make changes to this bug.