Bug 835423 - do not log ENOENT error found while crawling
do not log ENOENT error found while crawling
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: vsomyaju
:
: 837882 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 03:15 EDT by Raghavendra Bhat
Modified: 2015-03-04 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:39:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2012-06-26 03:15:11 EDT
Description of problem:
Suppose glustershd which is crawling over the list of entries to be self-healed finds that the entry which is to be self-healed is not found, then it is logging the message as an error. Its a valid case when 2 glustershds are crawling simulataneously and one of the glustershd already removed the entry as part of self-heal or the client process itself has removed the entry as part of the self-heal when lookup happened.

[2012-06-26 06:26:21.043576] I [afr-self-heald.c:282:_remove_stale_index] 0-master-replicate-0: Removing stale index for 3e052e29-1611-45a4-aaff-40dd95f77539 on master-client-1
[2012-06-26 06:26:21.043910] W [client3_1-fops.c:592:client3_1_unlink_cbk] 0-master-client-1: remote operation failed: No such file or directory
[2012-06-26 06:26:21.043936] E [afr-self-heald.c:287:_remove_stale_index] 0-master-replicate-0: 3e052e29-1611-45a4-aaff-40dd95f77539: Failed to remove index on master-client-1 - No such file or directory

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Pranith Kumar K 2012-07-26 12:50:10 EDT
*** Bug 837882 has been marked as a duplicate of this bug. ***
Comment 2 Vijay Bellur 2012-08-20 10:50:56 EDT
CHANGE: http://review.gluster.org/3826 (Self-heald: Prevent logging of errno ENOENT) merged in master by Anand Avati (avati@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.