Bug 83546 - ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 83560 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-05 10:41 EST by Aaron Freed
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Freed 2003-02-05 10:41:50 EST
Description of problem:
Unable to get true ATA100 performance from RedHat 7.3.  No matter what I do with
hdparm, I still get about 22 MB/sec transfer rate from the ATA100 IDE drive,
which is about what I get from my other two systems, both of which are only
ATA33-capable.

Version-Release number of selected component (if applicable):


How reproducible:
Guaranteed.  Cannot get any better performance! ;-<

Steps to Reproduce:
1.Install RedHat 7.3
2.Boot.  
3.Run hdparm -t /dev/hda1 as root
4.See poor result.
5.Be disappointed.

I seem to recall that there was a parameter I could pass to the kernel during
the boot process, by appending it to the end of the appropriate line in
/etc/grub.conf like this: (added parameter highlighted by "^^^^^^^^^"



    title Red Hat Linux (2.4.18-24.7.xbigmem)
        root (hd0,0)
        kernel /vmlinuz-2.4.18-24.7.xbigmem ro root=/dev/hda2 hdc=ide-scsi ide=ata66
^^^^^^^^^
        initrd /initrd-2.4.18-24.7.xbigmem.img


Actual results:

Have not tried it, yet.  Don't want to trash the central server with an
incorrect parameter!

Expected results:
data transfer rate of > 40 MB/s, as reported by hdparm -t /dev/hda

Additional info:
I know I reported this once before and Dave Ledford (I think?) kindly sent me
the instructions regarding a parameter similar to the above that fixed all my
problems and brought about World Peace (almost), but I cannot find that e-mail
or the original bug.  I'm really sorry to bother you with this again, and I
really do appreciate it!
Comment 1 Arjan van de Ven 2003-02-05 10:58:55 EST
the actual parameter is
ide0=ata66
for the first "cable", ide1=ata66 for the second cable etc etc.
Only do this if you have the 80 ribbon cable! 
Comment 2 Arjan van de Ven 2003-02-05 11:55:24 EST
*** Bug 83560 has been marked as a duplicate of this bug. ***
Comment 3 Aaron Freed 2003-02-05 14:05:29 EST
Thanks!  That seems to have sped things up a bit!  Can I get even more bang with
"ide=ata100", or does "ide=ata66" already include that?

Thanks again, Arjan!
Comment 4 Arjan van de Ven 2003-02-05 16:22:02 EST
ide0=ata66 already includes that. the only thing that matters is 40 vs 80 ribbon
cable; something that not always can be autodetected.
Comment 5 Bugzilla owner 2004-09-30 11:40:29 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.