Bug 835460 - An infinite loop happens when we use SysLogHandler with eventlet
An infinite loop happens when we use SysLogHandler with eventlet
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Malcolm
Petr Šplíchal
:
Depends On:
Blocks: 782252
  Show dependency treegraph
 
Reported: 2012-06-26 04:49 EDT by Alan Pevec
Modified: 2016-05-31 21:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-2.6.6-35.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:31:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Python 15179 None None None 2012-06-26 04:49:55 EDT

  None (edit)
Description Alan Pevec 2012-06-26 04:49:13 EDT
Description of problem:
If we stop a syslog daemon when running the following program, it
leads to an infinite loop.

Upstream bug report:
http://bugs.python.org/issue15179

Version-Release number of selected component (if applicable):
python-2.6.6-32.el6.x86_64

How reproducible:
Test script in upstream bug report.

send a message to logger
send a message to logger
send a message to logger
( kill rsyslog here)
Traceback (most recent call last):
  File "/usr/lib64/python2.6/logging/handlers.py", line 795, in emit
    self._connect_unixsocket(self.address)
  File "/usr/lib64/python2.6/logging/handlers.py", line 730, in _connect_unixsocket
    self.socket.connect(address)
  File "/usr/lib/python2.6/site-packages/eventlet/greenio.py", line 167, in connect
    while not socket_connect(fd, address):
  File "/usr/lib/python2.6/site-packages/eventlet/greenio.py", line 37, in socket_connect
    raise socket.error(err, errno.errorcode[err])
error: [Errno 2] ENOENT
send a message to logger

( restart rsyslog here, but test script does not continue)


PS I was NOT able to reproduce on F17 (python-2.7.3-6.fc17.x86_64) where rsyslog is socket activated.
Comment 3 RHEL Product and Program Management 2012-07-10 04:39:35 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:58:03 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 RHEL Product and Program Management 2012-08-14 18:00:56 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 10 errata-xmlrpc 2013-02-21 05:31:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0437.html

Note You need to log in before you can comment on or make changes to this bug.