Bug 835470 - Abrt claims problem is fixed in an already installed package
Abrt claims problem is fixed in an already installed package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2012-06-26 05:34 EDT by Kamil Páral
Modified: 2012-12-20 11:25 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:25:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (76.01 KB, image/png)
2012-06-26 05:34 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-06-26 05:34:57 EDT
Created attachment 594411 [details]
screenshot

Description of problem:
Abrt claims my problem is fixed in tracker-0.14.1-1.fc17 update. That's the same package as I have installed and that triggered the crash. That means the problem is *not* fixed, hmmm?

Abrt should detect I have the same version installed and re-open the bug instead.

Version-Release number of selected component (if applicable):
abrt-dbus-2.0.10-4.fc17.x86_64
abrt-libs-2.0.10-4.fc17.x86_64
abrt-addon-ccpp-2.0.10-4.fc17.x86_64
abrt-addon-python-2.0.10-4.fc17.x86_64
abrt-addon-vmcore-2.0.10-4.fc17.x86_64
abrt-desktop-2.0.10-4.fc17.x86_64
abrt-gui-2.0.10-4.fc17.x86_64
abrt-2.0.10-4.fc17.x86_64
abrt-addon-kerneloops-2.0.10-4.fc17.x86_64
abrt-retrace-client-2.0.10-4.fc17.x86_64
Comment 1 Jiri Moskovcak 2012-06-26 06:47:27 EDT
The question is what happened after you choosed that you really want to report it. On the other hand we can make the message say something different if you already have installed the package which should have the bug fixed.
Comment 2 Kamil Páral 2012-06-26 07:05:22 EDT
It said that analysis had failed and exit code was 1. Then I was able to continue and it added me to CC to that bug (but didn't attach any logs).

I don't think it should ask anything. It should reopen the bug. Bugzilla claims it's fixed, but it still crashes. What else to do?

But you have to make sure the package version that crashes is exactly the same (or higher) than the package version that is supposed to fix it. Because I could have updated the package in the mean time and only after that open up the abrt report. So you must not look at the installed package version, but look at the crashing package version (is that possible?). Or check yum log between the time of crash and current time, whether the package was upgraded in the mean time.
Comment 3 Denys Vlasenko 2012-09-20 10:09:29 EDT
Fixed in git:

commit fafc4d3ac0ae6c2bfef6543a245d0a2ee9df2866
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Thu Sep 20 16:05:35 2012 +0200

    bodhi: fix suggested pkg update command, fix version comparison
Comment 4 Fedora Update System 2012-09-24 10:31:32 EDT
abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
Comment 5 Fedora Update System 2012-09-24 16:03:42 EDT
Package abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.13-1.fc18 libreport-2.0.14-1.fc18 btparser-0.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14679/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-09-25 06:06:04 EDT
abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17
Comment 7 Fedora Update System 2012-12-20 11:25:12 EST
abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.