Bug 835479 - system-config-network should disable NM_CONTROLLED parameter
system-config-network should disable NM_CONTROLLED parameter
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-network (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
Branislav Blaškovič
:
Depends On:
Blocks: 1270825
  Show dependency treegraph
 
Reported: 2012-06-26 05:59 EDT by Toni Willberg
Modified: 2016-05-10 16:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:32:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2012-06-26 05:59:56 EDT
Description of problem:

 Network interface cannot be enabled by using only system-config-network.
 Manual editing of ifcfg-eth0 is required to set NM_CONTROLLED=no

Version-Release number of selected component (if applicable):
 system-config-network-tui-1.6.0.el6.2-1.el6.noarch

How reproducible:
 always

Steps to Reproduce:
1. ensure you don't have NetworkManager running
2. run system-config-network and edit eth0, set static IP
3. service network restart
  
Actual results:
 eth0 is not enabled, as see on ifconfig

Expected results:
 eth0 is active

Additional info:
 Proposed fixes: 
  a) overwrite NM_CONTROLLED parameter when using system-config-network-tui
  b) system-config-network should ask if user wants NetworkManager to control the interface yes/no
Comment 2 RHEL Product and Program Management 2012-07-10 04:36:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:12 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 RHEL Product and Program Management 2012-08-14 18:00:16 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 5 RHEL Product and Program Management 2012-12-14 03:33:43 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 Branislav Blaškovič 2016-02-08 09:26:05 EST
Version system-config-network-tui-1.6.0.el6.3-2.el6.noarch has checkbox "Controlled by NetworkManager". You can uncheck this and then it sets NM_CONTROLLED to no.

# grep NM_CONTR /etc/sysconfig/network-scripts/ifcfg-eth0 
NM_CONTROLLED=no
Comment 11 errata-xmlrpc 2016-05-10 16:32:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0792.html

Note You need to log in before you can comment on or make changes to this bug.