Bug 835487 - sar -y prints an error message on ppc64
sar -y prints an error message on ppc64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sysstat (Show other bugs)
7.0
ppc64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Peter Schiffer
BaseOS QE - Apps
:
Depends On:
Blocks: 879150
  Show dependency treegraph
 
Reported: 2012-06-26 06:36 EDT by Milos Malik
Modified: 2012-11-22 03:24 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 879150 (view as bug list)
Environment:
Last Closed: 2012-11-14 05:52:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-06-26 06:36:37 EDT
https://beaker.engineering.redhat.com/tasks/executed?task=/CoreOS/selinux-policy/Regression/bz485078-wrong-context-for-sysstat&job_id=252821

Version-Release number of selected component (if applicable):
RHEL-7.0-20120620.n.0

Steps to Reproduce:
* get a ppc64 machine with RHEL-7.0 installed
* run following automated test on the machine:
  /CoreOS/selinux-policy/Regression/bz485078-wrong-context-for-sysstat

Actual results:
# sar -y
Requested activities not available in file /var/log/sa/sa25

Expected results:
* sar -y produces the same output on all architectures
Comment 1 Milos Malik 2012-06-26 06:37:58 EDT
Sorry, here is the URL where you can see the problem:

http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2012/06/2528/252821/538648/6550667/TESTOUT.log
Comment 2 Peter Schiffer 2012-08-01 12:24:30 EDT
Hi Milos,

please, what's the content of the /proc/tty/driver/serial file?
And what's the output of this command? (needs to be run as root):
# sar -y 1 1

Was that a virtual machine? There may be a problem with some virtual machines, see bug #715300

Thanks,

peter
Comment 3 Peter Schiffer 2012-08-16 07:32:11 EDT
Hi Milos,

I've tried RHEL-7.0-20120711.2, ppc64 on ibm-p730-02-lp1.rhts.eng.bos.redhat.com machine.

Content of /proc/tty/driver/serial file is following:
# cat /proc/tty/driver/serial
serinfo:1.0 driver revision:
0: uart:unknown port:00000000 irq:0
1: uart:unknown port:00000000 irq:0
2: uart:unknown port:00000000 irq:0
3: uart:unknown port:00000000 irq:0

what means, that there are no statistics available for sar.

So.. this is not a sysstat bug. But I can't tell whether it is notabug or bug for kernel or something..
Comment 5 Milos Malik 2012-11-14 02:24:53 EST
I haven't seen the error message for a long time. Maybe it's fixed. Because it seems not to be a sysstat bug we can close it as NOTABUG. If I encounter the error message again, I will report it against kernel and I will add you to CC list.
Comment 6 Peter Schiffer 2012-11-14 05:52:00 EST
I agree. Closing as NOTABUG. Thanks.

Note You need to log in before you can comment on or make changes to this bug.