Bug 835491 - [abrt] yum-3.4.3-26.fc17: yumRepo.py:232:populate:URLGrabError: [Errno -1] Decompress DB failed
[abrt] yum-3.4.3-26.fc17: yumRepo.py:232:populate:URLGrabError: [Errno -1] De...
Status: CLOSED DUPLICATE of bug 831918
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-26 06:54 EDT by Alexey Larkov
Modified: 2014-01-21 18:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-06-26 08:00:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexey Larkov 2012-06-26 06:54:58 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available ad
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.4.3-1.fc17.x86_64
time:           Tue 26 Jun 2012 04:05:40 PM YEKT
uid:            1000
username:       larkov

:yumRepo.py:232:populate:URLGrabError: [Errno -1] Decompress DB failed
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 88, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 82, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2676, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 777, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 337, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 232, in populate
:    raise URLGrabError(-1, 'Decompress DB failed')
:URLGrabError: [Errno -1] Decompress DB failed
:Local variables in innermost frame:
:xml: '/var/tmp/yum-larkov-40tZv1/x86_64/17/google-chrome/primary.xml.gz'
:repo_cache_function: <bound method RepodataParserSqlite.getPrimary of <sqlitecachec.RepodataParserSqlite instance at 0x369e050>>
:mymdtype: 'primary'
:mydbtype: 'primary_db'
:self: <yum.sqlitesack.YumSqlitePackageSack object at 0x3696150>
:repo_get_function: <bound method YumRepository.getPrimaryXML of <yum.yumRepo.YumRepository object at 0x7fe23c54a3d0>>
:ret: None
:cacheonly: 0
:repo: <yum.yumRepo.YumRepository object at 0x7fe23c54a3d0>
:item: 'metadata'
:callback: None
:mdtype: 'metadata'
:data: ['metadata']
:gen: 'primary.xml'
:db_fn: None

:yum install <localfile>.rpm
:Error occured on press tab to autocomplete local file name
Comment 1 Zdeněk Pavlas 2012-06-26 08:00:08 EDT
This is likely a dupe of bug 831918, fixed in yum-3.4.3-28.fc17.  Please reopen if this persists.

*** This bug has been marked as a duplicate of bug 831918 ***

Note You need to log in before you can comment on or make changes to this bug.