Bug 835537 - UI should raise a validation error when user tries to create a gpg-key without passing 'Name'
UI should raise a validation error when user tries to create a gpg-key withou...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 08:22 EDT by Sachin Ghai
Modified: 2013-08-16 14:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 16:41:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spinner is rotating when we upload a gpg-key without passing name and no validation error raised. (52.76 KB, image/png)
2012-06-26 08:22 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-06-26 08:22:26 EDT
Created attachment 594461 [details]
spinner is rotating when we upload a gpg-key without passing name and no validation error raised.

Description of problem:
UI remains in processing state and no validation error raised when user doesn't pass the gpg-key Name.

Version-Release number of selected component (if applicable):
latest puddle 2012-06-22-1
katello-0.1.318-1.el6cf.noarch

How reproducible:
always

Steps to Reproduce:
1. Go to content providers --> GPG keys --> New gpg-key
2. browser the key without passing name
3. click on upload
  
Actual results:
Nothing happens on UI, spinner keep on rotating. See the spinner left adjacent to org name in attachment.

Expected results:
UI should raise a validation error

Additional info:
Comment 1 Jeff Weiss 2012-06-27 09:35:54 EDT
This works for me.  When I follow the steps I get a red notification:
"Validation Failed:
    Name must contain at least 2 characters"

Katello Version: 0.2.43-1.git.0.87ee6d7.el6_3,  Firefox 13.0
Comment 2 Og Maciel 2012-06-27 11:26:17 EDT
Sachin, could you try to reproduce this again, specially using different browsers?
Comment 3 Sachin Ghai 2012-07-02 03:30:21 EDT
I tried with google chrome browser, there I'm getting proper error message:

--
Validation Failed:
Name must contain at least 2 characters
--

Looks like the issue is with older version of Firefox 3.6.26
Comment 4 Mike McCune 2013-08-16 14:16:47 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.