Bug 835547 - RFE:add manual for processcsv.py
RFE:add manual for processcsv.py
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-top (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 08:48 EDT by yuping zhang
Modified: 2013-03-04 00:18 EST (History)
5 users (show)

See Also:
Fixed In Version: virt-top-1.0.4-3.14.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:07:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuping zhang 2012-06-26 08:48:02 EDT
Description of problem:
Now,man processcsv.py will open virt-top manual,no independent manual 
for processcsv.py.

Version-Release number of selected component (if applicable):
virt-top-1.0.4-3.13.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.#man processcsv.py
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-07-10 02:18:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 21:58:47 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 yuping zhang 2012-09-29 02:58:03 EDT
Verified this issue with virt-top-1.0.4-3.14.el6.x86_64
#man virt-top
NAME
       processcsv.py - process virt-top CSV files

SUMMARY
        virt-top --csv data.csv
        processcsv.py < data.csv

DESCRIPTION
       virt-top is a top(1)-like utility for showing stats of virtualized
       domains.

       processcsv.py is a simple Python script that post-processes the output of
       "virt-top --csv".

       It is used like this:

        virt-top --csv data.csv
        processcsv.py < data.csv

       The second command will overwrite the following files in the current
       directory:

       "global.csv"
           This contains the global (host) statistics columns from the CSV file.

       "domainNN.csv" (multiple files)
           For each libvirt domain ID NN, a file is created containing the per-
           domain statistics from the CSV file.

SEE ALSO
       virt-top(1)

AUTHORS
       Richard W.M. Jones <rjones @ redhat . com>

COPYRIGHT
       (C) Copyright 2007-2012 Red Hat Inc., Richard W.M. Jones
       http://libvirt.org/

       This program is free software; you can redistribute it and/or modify it
       under the terms of the GNU General Public License as published by the
       Free Software Foundation; either version 2 of the License, or (at your
       option) any later version.

       This program is distributed in the hope that it will be useful, but
       WITHOUT ANY WARRANTY; without even the implied warranty of
       MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General
       Public License for more details.

       You should have received a copy of the GNU General Public License along
       with this program; if not, write to the Free Software Foundation, Inc.,
       675 Mass Ave, Cambridge, MA 02139, USA.

virt-top-1.0.4                    2012-09-28                  PROCESSCSV.PY(1)

Change the bug status to VERIFIED.
Comment 5 yuping zhang 2012-09-29 03:22:36 EDT
I found a little problem:
In virt-top manual page:
#man virt-top
...
 virt-top --csv data.csv
            processcsv.py < data.csv

           This creates or overwrites the following files in the current
           directory:

            global.csv
            domain<NNN>.csv

           "global.csv" will contain the global data.  One "domain<NNN>.csv"
           file will also be created for each domain with ID "NNN", containin
...

==> The file is described domian<NNN>.csv

In processscv.py manual page:
...
       "domainNN.csv" (multiple files)
           For each libvirt domain ID NN, a file is created containing the per-
           domain statistics from the CSV file.
...

==> The file is described domanNN.csv

Hi Richard,
The file name should be consistency,right?
Comment 6 Richard W.M. Jones 2012-09-29 03:48:50 EDT
"NN" means a domain ID, eg. domain123.csv.
Comment 7 yuping zhang 2012-09-29 04:01:28 EDT
(In reply to comment #6)
> "NN" means a domain ID, eg. domain123.csv.

Hi Richard,
I know that,I mean the file need to be described same.For example,both them describe the file as domian<NNN>.csv or domainNN.csv.
Comment 9 errata-xmlrpc 2013-02-21 05:07:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0391.html

Note You need to log in before you can comment on or make changes to this bug.