Bug 835572 - Comparison of storage volume formats
Comparison of storage volume formats
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Administration_Guide (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 6.4
Assigned To: Laura Novich
ecs-bugs
: Documentation
Depends On:
Blocks: 861282 861285
  Show dependency treegraph
 
Reported: 2012-06-26 09:53 EDT by Martin Prpič
Modified: 2016-01-26 20:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 861282 861285 (view as bug list)
Environment:
Last Closed: 2013-02-25 02:05:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Prpič 2012-06-26 09:53:07 EDT
Please include a comparison of all available storage volume formats:

* raw
* cow
* qcow
* qcow2
* qed
* vdmk
* vpc
Comment 2 Laura Novich 2012-09-27 09:06:55 EDT
Kevin,
can you please supply me with some information?
Laura
Comment 3 Kevin Wolf 2012-09-27 10:29:52 EDT
Note that the original report does not include all image formats that qemu-img can handle in RHEL 6. For a hopefuly complete list with a description please see the man page of qemu-img.

In short, we support these native formats:

* raw: Optimal performance, only very basic features (no snapshots etc.)
* qcow2: Full features, at the cost of some performance
* qed: Included only at IBM's request; has less features than qcow2, but can perform a bit better in some specific cases (cache=writethrough). We won't support it as a native format in RHEL 7, please warn against using it.

The other formats are for compatibility with other virtualisation software. They cannot be used for running VMs in RHEL, but only for qemu-img. The idea is that you convert them to raw or qcow2 before using them with KVM.
Comment 7 Kevin Wolf 2012-09-28 06:19:54 EDT
qed should either not be mentioned at all, or we should warn against using it because it's a dead end and won't be included in future releases. It's description is sub-standard, too (typos, formatting, grammar...)

Also I'm afraid that I didn't describe the distinction between native and compatibility formats precise enough: Native formats can be used to run VMs and also for qemu-img, this is described correctly. Compatibility formats cannot be used to run VMs, but they can be used for all kinds of qemu-img operation, so amongst others you cannot only convert from, but also to them.
Comment 8 John Skeoch 2012-10-01 21:41:11 EDT
Moving back to assigned until comment#7 is addressed.

Note You need to log in before you can comment on or make changes to this bug.