Bug 835583 - [abrt] yum-3.4.3-26.fc17: yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot access repository dir /var/tmp/yum-anton-z4vOxv/x86_64/17/Dropbox
[abrt] yum-3.4.3-26.fc17: yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot a...
Status: CLOSED DUPLICATE of bug 830523
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:4ca448b9f1ccd42e3e013494d02...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 10:24 EDT by Anton Arapov
Modified: 2014-06-18 04:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-26 10:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Arapov 2012-06-26 10:24:16 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list all kexec-to
executable:     /usr/share/yum-cli/completion-helper.py
kernel:         3.4.3-4.fc17.x86_64
time:           Tue 26 Jun 2012 16:21:38 CEST
uid:            1000
username:       anton

backtrace:
:yumRepo.py:614:_dirSetupMkdir_p:RepoError: Cannot access repository dir /var/tmp/yum-anton-z4vOxv/x86_64/17/Dropbox
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 88, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 82, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2611, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1013, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 777, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 300, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 125, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 81, in retrieveAllMD
:    if repo._async and repo._commonLoadRepoXML(repo):
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1315, in _commonLoadRepoXML
:    local  = self.cachedir + '/repomd.xml'
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 682, in <lambda>
:    cachedir = property(lambda self: self._dirGetAttr('cachedir'))
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 665, in _dirGetAttr
:    self.dirSetup()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 644, in dirSetup
:    self._dirSetupMkdir_p(dir)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 614, in _dirSetupMkdir_p
:    raise Errors.RepoError, "Cannot access repository dir %s" % dpath
:RepoError: Cannot access repository dir /var/tmp/yum-anton-z4vOxv/x86_64/17/Dropbox
:
:Local variables in innermost frame:
:self: <yum.yumRepo.YumRepository object at 0x1d3db10>
:dpath: '/var/tmp/yum-anton-z4vOxv/x86_64/17/Dropbox'

comment:
:just one step to reproduce:
:  $ sudo yum search kexe[TAB] <- for bash-autocomplete
Comment 1 Zdeněk Pavlas 2012-06-26 10:28:26 EDT

*** This bug has been marked as a duplicate of bug 830523 ***

Note You need to log in before you can comment on or make changes to this bug.