Bug 835589 - [ovirt-engine-backend] Preview of snapshot fails
[ovirt-engine-backend] Preview of snapshot fails
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
x86_64 Linux
medium Severity unspecified
: ---
: 3.1.0
Assigned To: Oved Ourfali
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 10:30 EDT by Kiril Nesenko
Modified: 2016-02-10 12:14 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 07:49:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (650.10 KB, application/x-bzip)
2012-06-26 10:30 EDT, Kiril Nesenko
no flags Details

  None (edit)
Description Kiril Nesenko 2012-06-26 10:30:41 EDT
Created attachment 594495 [details]
logs

Description of problem:
Preview of snapshot fails

2012-06-26 17:15:00,011 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-33) Autorecovering 0 storage domains
2012-06-26 17:15:00,011 INFO  [org.ovirt.engine.core.bll.AutoRecoveryManager] (QuartzScheduler_Worker-33) Checking autorecoverable storage domains done
2012-06-26 17:19:03,940 INFO  [org.ovirt.engine.core.utils.transaction.TransactionSupport] (pool-4-thread-46) transaction rolled back
2012-06-26 17:19:03,961 ERROR [org.ovirt.engine.core.bll.EntityAsyncTask] (pool-4-thread-46) EntityAsyncTask::EndCommandAction [within thread]: EndAction for action type TryBackToAllSnapshotsOfVm threw an except
ion: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.rangeCheck(ArrayList.java:571) [rt.jar:1.6.0_24]
        at java.util.ArrayList.get(ArrayList.java:349) [rt.jar:1.6.0_24]
        at org.ovirt.engine.core.bll.snapshots.SnapshotsManager.removeDisksNotInSnapshot(SnapshotsManager.java:369) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.snapshots.SnapshotsManager.synchronizeDisksFromSnapshot(SnapshotsManager.java:357) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.snapshots.SnapshotsManager.attempToRestoreVmConfigurationFromSnapshot(SnapshotsManager.java:214) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.TryBackToAllSnapshotsOfVmCommand.EndSuccessfully(TryBackToAllSnapshotsOfVmCommand.java:72) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.InternalEndSuccessfully(CommandBase.java:466) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.endActionInTransactionScope(CommandBase.java:421) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1206) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInNewTransaction(TransactionSupport.java:204) [engine-utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInRequired(TransactionSupport.java:142) [engine-utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:109) [engine-utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.EndAction(CommandBase.java:367) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.Backend.endAction(Backend.java:356) [engine-bll.jar:]
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.6.0_24]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.6.0_24]



Version-Release number of selected component (if applicable):
si7
vdsm-4.9.6-17.0.el6.x86_64
libvirt-0.9.10-21.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Have to snapshots for vm.
2. Try to preview the second one
3.
  
Actual results:
Preview fails

Expected results:


Additional info:
Was tested on nfs storage domain.
Comment 1 Oved Ourfali 2012-06-28 07:49:48 EDT
I tried to reproduce it on latest upstream, and preview succeeded for both snapshots.
Also, tried to use floating disks as well, and it succeeded as well.
(Did the test as you said, on nfs storage domain).
Comment 2 Yaniv Kaul 2012-06-28 08:00:18 EDT
(In reply to comment #1)
> I tried to reproduce it on latest upstream, and preview succeeded for both
> snapshots.

This bug is on downstream, not upstream, therefore I recommend testing with downstream build.

> Also, tried to use floating disks as well, and it succeeded as well.
> (Did the test as you said, on nfs storage domain).

Note You need to log in before you can comment on or make changes to this bug.