Bug 835598 - [RHEVM] [backend] [Setup Host Networks] setting static IP on VLANed rhevm interface sends options={'bootproto': 'dhcp'}
[RHEVM] [backend] [Setup Host Networks] setting static IP on VLANed rhevm int...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Moti Asayag
Martin Pavlik
network
:
Depends On: 845494
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 10:46 EDT by Martin Pavlik
Modified: 2016-02-10 14:51 EST (History)
9 users (show)

See Also:
Fixed In Version: si13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:04:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log + engine.log + ifcfg files (14.79 KB, application/x-gzip)
2012-06-26 10:46 EDT, Martin Pavlik
no flags Details
screenshot 1 (179.30 KB, image/png)
2012-06-26 10:46 EDT, Martin Pavlik
no flags Details
screenshot 2 (203.45 KB, image/png)
2012-06-26 10:47 EDT, Martin Pavlik
no flags Details
logs2 (21.11 KB, application/x-gzip)
2012-07-18 08:26 EDT, Martin Pavlik
no flags Details
screenshot 3 (208.50 KB, image/png)
2012-07-18 10:31 EDT, Martin Pavlik
no flags Details
logs3 (9.38 KB, application/x-gzip)
2012-07-18 10:37 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Martin Pavlik 2012-06-26 10:46:07 EDT
Created attachment 594498 [details]
vdsm.log + engine.log + ifcfg files

Description of problem: 
If host is added to setup over VLANed interface with static configuration. 2 problems occur. 


1) Rhevm interface is seen as DHCP configured despite it has static configuration (see screenshot 1, and ifcfg files in folder ifcfg_before) 

2) When user tries to change DHCP to static via SetupNetworks dialog,  options={'bootproto': 'dhcp'} is received by vdsm. (see scrrenshot 2 with interface settings), vdsm.log, engine.log and ifcfg files after change attached.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.1.0-2.el6ev 
vdsm-4.9.6-17.0.el6.x86_64
Host is RHEL 6.3


How reproducible:
100%

Steps to Reproduce:
1. Create new Data Center with VLAN tagged rhevm network
2. Add cluster to DC
3. Add host to cluster over VLAN tagged interface (manually configured before adding to setup)
4. Go to hosts -> your host -> setup host networks -> click pencil icon on rhevm interface -> you will see DHCP checked (screenshot 1)
5. switch to static configuration -> fill in IP/MASK/GW -> click OK -> check Save network configuration -> click OK

rhevm interface configuration should changetto DHCP


Actual results:
1)interface configured with static IP is shown with DHCP checkbox
2)static configuration in GUI results in DHCP configuration on host

Expected results:
1) interface configured with static IP is shown as configured with static IP
2) static configuration in GUI results in static configuration on host

Additional info:
Comment 1 Martin Pavlik 2012-06-26 10:46:47 EDT
Created attachment 594499 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-06-26 10:47:03 EDT
Created attachment 594500 [details]
screenshot 2
Comment 3 lpeer 2012-07-17 03:36:35 EDT
Moti -looks like a dup of 824432
Comment 6 Martin Pavlik 2012-07-18 08:26:02 EDT
Created attachment 598870 [details]
logs2
Comment 8 Martin Pavlik 2012-07-18 10:31:45 EDT
Created attachment 598904 [details]
screenshot 3
Comment 9 Martin Pavlik 2012-07-18 10:37:33 EDT
Created attachment 598905 [details]
logs3

Note You need to log in before you can comment on or make changes to this bug.