Bug 835631 - /etc/cron.daily/polipo returns failure if polipo is not running
/etc/cron.daily/polipo returns failure if polipo is not running
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: polipo (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 12:18 EDT by Colin.Simpson
Modified: 2012-12-11 19:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-11 19:31:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin.Simpson 2012-06-26 12:18:26 EDT
Description of problem:

If the polipo server isn't running cron.daily generates an email:

From: 	Anacron <root@localhost.localdomain>
To: 	root@localhost.localdomain
Subject: 	Anacron job 'cron.daily' on fedoratest
Date: 	Tue, 26 Jun 2012 03:09:41 +0100


/etc/cron.daily/polipo:

 ...killed.


Version-Release number of selected component (if applicable):
polipo-1.0.4.1-6.fc17.x86_64

How reproducible:
Every time


Steps to Reproduce:
1. Let cron.daily run and have no polipo service running.  


Additional info:

Looks like this bug from Debian, which has more details. The fix looks trivial.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=660840
Comment 1 Fedora Update System 2012-12-02 21:25:18 EST
polipo-1.0.4.1-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/polipo-1.0.4.1-9.fc18
Comment 2 Fedora Update System 2012-12-03 16:41:36 EST
Package polipo-1.0.4.1-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing polipo-1.0.4.1-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19595/polipo-1.0.4.1-9.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-12-11 19:31:51 EST
polipo-1.0.4.1-9.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.