Bug 835641 - cannot resume system from suspend/hibernate
cannot resume system from suspend/hibernate
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-26 13:05 EDT by hramrach
Modified: 2013-07-31 22:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-31 22:11:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description hramrach 2012-06-26 13:05:23 EDT
suspend to ram:

1) run pm-suspend

kernel panics

suspend to disk:

1) run pm-hibernate
2) boot

no display output (display off, keyboard leds seem working)

hardware: http://www.smolts.org/client/show/pub_74da9a3b-ef28-4a84-9d98-a6698642cb6a
Comment 1 Josh Boyer 2012-07-06 10:38:56 EDT
Can you attach the output of the kernel panic?

Which kernel(s) have this problem?

Has suspend/hibernate worked on this machine previously?  If so, which versions of the kernel worked before?
Comment 2 hramrach 2012-07-09 02:07:14 EDT
the kernel with which f17 installs.

the one from f17 updates does not panic, merely locks up on resume.

This is how the system always 'worked'.

resume from s2d only ever worked on Debian which avoids entering graphics mode before attempting resume, not the way Fedora resumes

kexec works, however.

For unknown reason the code used in initialization is not used in resume from hibernation leading to errors like this on many systems (all I tried in fact although the radeon developers claim that on many systems their code works).
Comment 3 hramrach 2012-07-13 11:29:11 EDT
resuming with UMS (nomodeset) seems to work flawlessly.

Tried a few times and no lockup.
Comment 4 Fedora End Of Life 2013-07-03 19:28:36 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 22:11:16 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.