Bug 835671 - php depends on libevent-devel when it shouldn't
php depends on libevent-devel when it shouldn't
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 15:07 EDT by Ross Lagerwall
Modified: 2012-07-11 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 20:01:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which fixes the issue. (423 bytes, patch)
2012-06-26 15:07 EDT, Ross Lagerwall
no flags Details | Diff

  None (edit)
Description Ross Lagerwall 2012-06-26 15:07:18 EDT
Created attachment 594573 [details]
Patch which fixes the issue.

php-fpm depends on libevent when it doesn't need to (it doesn't use it).

The attached patch fixes this issue.
Comment 1 Remi Collet 2012-06-27 00:46:48 EDT
Upstream bug related
https://bugs.php.net/bug.php?id=52501
https://bugs.php.net/bug.php?id=52498

Yes this BuildRequires should have be removed (since 5.3.4)
But php doesn't requires libevent (check: yum remove libevent doesn't pull php)
Comment 2 Ross Lagerwall 2012-06-27 12:49:23 EDT
Sorry, yes I meant php build-requires libevent-devel when it doesn't need to (none of the packages it creates depend on libevent).
Comment 3 Fedora Update System 2012-07-02 12:55:19 EDT
php-5.4.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/php-5.4.4-4.fc17
Comment 4 Fedora Update System 2012-07-02 18:28:25 EDT
Package php-5.4.4-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-5.4.4-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10159/php-5.4.4-4.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-07-11 20:01:17 EDT
php-5.4.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.