Bug 835704 - your current installation cannot be upgraded
your current installation cannot be upgraded
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 887494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 17:34 EDT by Henrique Martins
Modified: 2013-01-10 01:50 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 16:33:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (3.44 KB, text/plain)
2012-06-26 19:21 EDT, Henrique Martins
no flags Details
storage.log (67.75 KB, text/plain)
2012-06-26 19:22 EDT, Henrique Martins
no flags Details
program.log (32.46 KB, text/plain)
2012-06-26 19:22 EDT, Henrique Martins
no flags Details
X.log (76.66 KB, text/plain)
2012-06-26 19:23 EDT, Henrique Martins
no flags Details
syslog (113.65 KB, text/plain)
2012-06-26 19:23 EDT, Henrique Martins
no flags Details

  None (edit)
Description Henrique Martins 2012-06-26 17:34:15 EDT
Description of problem:
Plain F16 x86_64 system, yum upgraded from some Fxx install through F16, never skipping any release.  Boots fine, knows it is F16.  Small (200 MB) /dev/sda1 on /boot.  LVM on /dev/sda2 with 5 GB swap and 150 GB root.
Trying to upgrade via DVD complains "your current installation cannot be upgraded".


Version-Release number of selected component (if applicable):
anaconda from F17 DVD

How reproducible:
Always

Steps to Reproduce:
1. Load F17 DVD, run through install
  
Actual results:
Complains version is too old, refuses to update

Expected results:
Update proceeding normally.

Additional info:
I cloned the system into a different disk (with a larger /boot so preupgrade may work as system is on fixed IP, thus getting stage2 doesn't work as the DHCP assigned IP can't get through the firewall...) and put the disk on a spare computer, thus can test this if someone wants to find out the cause.

We'll need to upgrade the system though.  Fresh install is not a nice option
Comment 1 Brian Lane 2012-06-26 19:02:00 EDT
What does /etc/redhat-release have in it?

Also, please attach the logs from /tmp/*log as individual text/plain files.
Comment 2 Henrique Martins 2012-06-26 19:20:37 EDT
/etc/redhat-releasee (as well as fedora-release) contains
Fedora release 16 (Verne)
Will attaching all logs
Comment 3 Henrique Martins 2012-06-26 19:21:25 EDT
Created attachment 594627 [details]
anaconda.log
Comment 4 Henrique Martins 2012-06-26 19:22:05 EDT
Created attachment 594628 [details]
storage.log
Comment 5 Henrique Martins 2012-06-26 19:22:27 EDT
Created attachment 594629 [details]
program.log
Comment 6 Henrique Martins 2012-06-26 19:23:02 EDT
Created attachment 594630 [details]
X.log
Comment 7 Henrique Martins 2012-06-26 19:23:26 EDT
Created attachment 594631 [details]
syslog
Comment 8 Brian Lane 2012-06-27 12:39:04 EDT
It doesn't seem to like your release string, even though what you posted in comment 2 looks fine:

16:09:43,457 INFO storage: product None, version None, arch x86_64 found on penguin_vg-root is not upgradable
16:09:43,457 DEBUG storage: test results: {'product': False, 'version': False, 'arch': True}
Comment 9 Henrique Martins 2012-06-27 13:28:47 EDT
I think I found the problem/bug.

I have a real file:
  /etc/fedora-release
containing:
  Fedora release 16 (Verne)

I have a symlink pointing to it via a relative path:
  /etc/system-release -> fedora-release

I have another symlink pointing to that symlink, using an absolute path:
  /etc/redhat-release -> /etc/system-release

When anaconda runs from the DVD the absolute path doesn't really point to my fedora-release file.

I changed system-release to point directly/relatively to fedora-release and now anaconda finds my system and wants to updated.

I'm pretty sure I didn't create or mess with any of the files above, and they are just as created by my initial install and yum upgraded systems ...
Comment 10 Henrique Martins 2012-06-27 13:55:32 EDT
Just looked at my two remaining F16 systems, besides the one where I saw this problem, and in them both /etc/system-release and /etc/redhat-release are symlinks pointing to fedora-release (relative), so the problem existed on only  one of my machines.
Comment 11 Jesse Keating 2012-06-27 16:33:08 EDT
Really points to some local misconfiguration or one-shot bug.  Not much we can do about that here/now.
Comment 12 Sandro 2012-12-22 15:50:25 EST
*** Bug 887494 has been marked as a duplicate of this bug. ***
Comment 13 Henrique Martins 2012-12-23 12:25:00 EST
Seems like Sandro (comment 12 here, and bug 887494) ran into the same problem, so now we have two people which had the same local misconfiguration, or, most likely, the result of a previous upgrade, as I'm pretty sure I never touched those files.
Probably a moot problem by now, unless someone runs into going from f71 to f18.

Note You need to log in before you can comment on or make changes to this bug.