Bug 83573 - gnome icon theme should have Inherits=hicolor
Summary: gnome icon theme should have Inherits=hicolor
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-artwork (Show other bugs)
(Show other bugs)
Version: phoebe
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-02-05 18:37 UTC by Ngo Than
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 23:55:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ngo Than 2003-02-05 18:37:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2.1) Gecko/20030203

Description of problem:
with bluecurve icon theme, some kde applications (like kdevelop) does not show
the icons correct in the toolbar.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. switch to bluecurve icon theme in KDE enviroment
2. start kdevelop
3. look the icons on the toolbar
    

Actual Results:  icons on the toolbar are not displayed correct

Expected Results:  icons should be displayed correct on the toolbar

Additional info:

Add Inherits=hicolor into gnome.index should fix this problem

Comment 1 Havoc Pennington 2003-02-05 19:01:07 UTC
alex understands the issues here.

Comment 2 Alexander Larsson 2003-02-10 11:54:25 UTC
gnome-icon-theme 0.1.0-3 building now has this fix.
But its more of a workaround than a fix. The bug is in KDE. According to the
spec and what we agreed on you should *always* read in the hicolor theme. no
matter what.

This "fix" makes redhat-artwork depend on gnome-icon-theme for KDE. A real fix
to kdelibs would not require that.

Comment 3 Alexander Larsson 2003-02-10 11:56:11 UTC
The dependency is: if the "gnome" theme that Bluecurve inherits from doesn't
exists that shouldn't cause any problems for KDE, but now it probably does,
because kde doesn't load the hicolor theme. (I didn't test this though.)


Comment 4 Ngo Than 2003-02-17 15:18:06 UTC
it's fixed now in 0.66.


Note You need to log in before you can comment on or make changes to this bug.