Bug 835740 - Cannot do anything about slow Keys turning themselves on in XFCE
Cannot do anything about slow Keys turning themselves on in XFCE
Status: CLOSED DUPLICATE of bug 816764
Product: Fedora
Classification: Fedora
Component: xfce4-settings (Show other bugs)
18
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 22:25 EDT by Peter Backes
Modified: 2013-07-16 21:43 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 14:03:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 9088 None None None 2012-07-05 16:24:06 EDT

  None (edit)
Description Peter Backes 2012-06-26 22:25:57 EDT
Description of problem:
Slow keys turn themselves on by pressing shift for 10 seconds in xfce. "Settings => Accessibility => Use slow keys" is turned off, and it stays turned off even when the change is triggered. If you don't know what happened and how to undo it (press shift for 10 seconds again), this can be extremely confusing. The problem first occurred after I upgraded to f17.

Version-Release number of selected component (if applicable):
xfce4-settings-4.8.3-4.fc17.i686
xorg-x11-server-common-1.12.2-4.fc17.i686
xorg-x11-server-Xorg-1.12.2-4.fc17.i686
gdm-3.4.1-3.fc17.i686

How reproducible:
always

Steps to Reproduce:
1. login to some xfce session
2. press shift for 10 seconds

Actual results:
Notification "Slow Keys  Slow Keys are enabled" pops up, having the suggested effect.

Expected results:
nothing happens, unless the user enables such behavior.

Additional info:
see also bug 816764: "This appears to be an xfce bug then. Please file it separately."

Using gdm.
Comment 1 Kevin Fenzi 2012-07-05 16:24:06 EDT
Upstream bug: 

https://bugzilla.xfce.org/show_bug.cgi?id=9088
Comment 2 Nadav Har'El 2012-08-04 18:10:56 EDT
This is not entirely a "xfce bug". It is an X server mis-feature ("slowkeys") that is *wrongly* on by default, and thus effects any desktop environment, not just xfce.

The only "xfce bug" part of all of this is the fact it doesn't know that X has accesssx enabled by default (I don't know why this is happening - xkbset recommended in bug 816764 seems to control this feature fine).

But the bigger bug is that X has this "feature" enabled by default...
Comment 3 Aleksandar Kostadinov 2012-12-17 16:33:42 EST
affects fedora 18 it seems
Comment 4 Kevin Fenzi 2012-12-17 16:51:35 EST
Only when using gdm, right?

It seems a gdm issue to me, as lightdm + Xfce never had this problem.
Comment 5 Aleksandar Kostadinov 2012-12-17 17:01:25 EST
@Kevin, you are correct.
Comment 6 Jan Pazdziora 2013-07-16 13:51:00 EDT
Is this a duplicate of bug 816764?
Comment 7 Kevin Fenzi 2013-07-16 14:03:27 EDT
Yeah, likely so.

*** This bug has been marked as a duplicate of bug 816764 ***
Comment 8 Peter Backes 2013-07-16 21:43:11 EDT
This bug was specifically opened because Peter Hutterer wrote at bug 816764 that "This appears to be an xfce bug then. Please file it separately." (as noted in additional info here).

Note You need to log in before you can comment on or make changes to this bug.