Bug 83575 - up2date-nox is complaining about missing RPM-GPG-KEY.
up2date-nox is complaining about missing RPM-GPG-KEY.
Status: CLOSED DUPLICATE of bug 83003
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-05 13:57 EST by Ivo Sarak
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2003-02-05 13:57:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
Even the RPM-GPG-KEY is there and is being updated - "up2date-nox -u" will fail
to start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run "up2date-nox -u"


Actual Results:  [root@skhal rhn]# up2date-nox -u
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@skhal rhn]# rpm --import /usr/share/rhn/RPM-GPG-KEY
[root@skhal rhn]# up2date-nox -u
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@skhal rhn]#

Expected Results:  No error messages and up2date should start working.

Additional info:

[root@skhal rhn]# ls -la /usr/share/rhn/
total 40
drwxr-xr-x    6 root     root         4096 Feb  5 20:42 .
drwxr-xr-x  187 root     root         4096 Feb  2 17:01 ..
drwxr-xr-x    2 root     root         4096 Feb  2 17:01 actions
-rw-r--r--    1 root     root         1489 Jan 16 10:12 BETA-RPM-GPG-KEY
-rwxr-xr-x    1 root     root            0 Jan 16 10:12 __init__.py
drwxr-xr-x    2 root     root         4096 Oct 20 12:09 register
drwxr-xr-x    2 root     root         4096 Aug 11 22:24 rhn_applet
-rw-r--r--    1 root     root         7638 Jan 16 10:12 RHNS-CA-CERT
-rw-r--r--    1 root     root         1913 Jan 16 10:12 RPM-GPG-KEY
drwxr-xr-x    2 root     root         4096 Feb  2 21:48 up2date_client
[root@skhal rhn]#
[root@skhal rhn]# cat /usr/share/rhn/RPM-GPG-KEY
The following public key can be used to verify RPM packages built and
signed by Red Hat Software using `rpm -K' using the GNU GPG package.
Questions about this key should be sent to security@redhat.com.

-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1.0.0 (GNU/Linux)
Comment: For info see http://www.gnupg.org

mQGiBDfqVDgRBADBKr3Bl6PO8BQ0H8sJoD6p9U7Yyl7pjtZqioviPwXP+DCWd4u8
HQzcxAZ57m8ssA1LK1Fx93coJhDzM130+p5BG9mYSWShLabR3N1KXdXQYYcowTOM
GxdwYRGr1Spw8QydLhjVfU1VSl4xt6bupPbWJbyjkg5Z3P7BlUOUJmrx3wCgobNV
EDGaWYJcch5z5B1of/41G8kEAKii6q7Gu/vhXXnLS6m15oNnPVybyngiw/23dKjS
ZVG7rKANEK2mxg1VB+vc/uUc4k49UxJJfCZg1gu1sPFV3GSa+Y/7jsiLktQvCiLP
lncQt1dV+ENmHR5BdIDPWDzKBVbgWnSDnqQ6KrZ7T6AlZ74VMpjGxxkWU6vV2xsW
XCLPA/9P/vtImA8CZN3jxGgtK5GGtDNJ/cMhhuv5tnfwFg4b/VGo2Jr8mhLUqoIb
E6zeGAmZbUpdckDco8D5fiFmqTf5+++pCEpJLJkkzel/32N2w4qzPrcRMCiBURES
PjCLd4Y5rPoU8E4kOHc/4BuHN903tiCsCPloCrWsQZ7UdxfQ5LQiUmVkIEhhdCwg
SW5jIDxzZWN1cml0eUByZWRoYXQuY29tPohVBBMRAgAVBQI36lQ4AwsKAwMVAwID
FgIBAheAAAoJECGRgM3bQqYOsBQAnRVtg7B25Hm11PHcpa8FpeddKiq2AJ9aO8sB
XmLDmPOEFI75mpTrKYHF6rkCDQQ36lRyEAgAokgI2xJ+3bZsk8jRA8ORIX8DH05U
lMH27qFYzLbT6npXwXYIOtVn0K2/iMDj+oEB1Aa2au4OnddYaLWp06v3d+XyS0t+
5ab2ZfIQzdh7wCwxqRkzR+/H5TLYbMG+hvtTdylfqIX0WEfoOXMtWEGSVwyUsnM3
Jy3LOi48rQQSCKtCAUdV20FoIGWhwnb/gHU1BnmES6UdQujFBE6EANqPhp0coYoI
hHJ2oIO8ujQItvvNaU88j/s/izQv5e7MXOgVSjKe/WX3s2JtB/tW7utpy12wh1J+
JsFdbLV/t8CozUTpJgx5mVA3RKlxjTA+On+1IEUWioB+iVfT7Ov/0kcAzwADBQf9
E4SKCWRand8K0XloMYgmipxMhJNnWDMLkokvbMNTUoNpSfRoQJ9EheXDxwMpTPwK
ti/PYrrL2J11P2ed0x7zm8v3gLrY0cue1iSba+8glY+p31ZPOr5ogaJw7ZARgoS8
BwjyRymXQp+8Dete0TELKOL2/itDOPGHW07SsVWOR6cmX4VlRRcWB5KejaNvdrE5
4XFtOd04NMgWI63uqZc4zkRa+kwEZtmbz3tHSdRCCE+Y7YVP6IUf/w6YPQFQriWY
FiA6fD10eB+BlIUqIw80VgjsBKmCwvKkn4jg8kibXgj4/TzQSx77uYokw1EqQ2wk
OZoaEtcubsNMquuLCMWijYhGBBgRAgAGBQI36lRyAAoJECGRgM3bQqYOhyYAnj7h
VDY/FJAGqmtZpwVp9IlitW5tAJ4xQApr/jNFZCTksnI+4O1765F7tA==
=3AHZ
-----END PGP PUBLIC KEY BLOCK-----
[root@skhal rhn]#
Comment 1 Adrian Likins 2003-02-07 13:09:13 EST
this is the same issue as #83003
(more or less a beta only/tui only bug... the
tui doesnt tell you that you need to import
the beta key as well. )

rpm --import /usr/share/rhn/BETA-RPM-GPG-KEY
is the workaround.

*** This bug has been marked as a duplicate of 83003 ***
Comment 2 Ivo Sarak 2003-02-08 04:32:13 EST
As You see from directory listing - there is a BETA-RPM-GPG-KEY.
As this system is running full RedHat 8.0 not some BETA Phoebe or something, why
is this BETA-RPM-GPG-KEY needed at all? 
Comment 3 Red Hat Bugzilla 2006-02-21 13:51:37 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.