Bug 835777 - Package redhat-lsb need requires libpng-compat, not libpng on F17 or rhel7
Package redhat-lsb need requires libpng-compat, not libpng on F17 or rhel7
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xibo Ning
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 01:56 EDT by Xibo Ning
Modified: 2013-05-22 14:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 14:32:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xibo Ning 2012-06-27 01:56:35 EDT
Description of problem:
Should fix redhat-lsb to support PPC64 and S390X
Comment 1 Xibo Ning 2012-07-01 22:28:16 EDT
Package libpng-compat stores libpng12.so.0 in Fedora 17 and rhel7. So need fix redhat-lsb to requires libpng-compat instead of libpng.
Comment 2 Fedora Update System 2012-07-02 10:57:59 EDT
redhat-lsb-4.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/redhat-lsb-4.1-5.fc17
Comment 3 Fedora Update System 2012-07-02 18:34:03 EDT
Package redhat-lsb-4.1-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing redhat-lsb-4.1-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10194/redhat-lsb-4.1-5.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-07-17 13:23:49 EDT
redhat-lsb-4.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Tom Lane 2012-07-23 00:16:31 EDT
This was fixed in completely the wrong way.  The package should be updated to use libpng 1.5. libpng-compat is not going to be shipped in F18.
Comment 6 Xibo Ning 2012-07-24 21:26:05 EDT
(In reply to comment #5)
> This was fixed in completely the wrong way.  The package should be updated
> to use libpng 1.5. libpng-compat is not going to be shipped in F18.

Thanks Tom. I think redhat-lsb will update to use libpng 1.5 when LSB 5.0 release.
Comment 7 Tom Lane 2012-07-24 21:55:24 EDT
(In reply to comment #6)
> Thanks Tom. I think redhat-lsb will update to use libpng 1.5 when LSB 5.0
> release.

Hm, when will that be?  I'd like to drop libpng 1.2 from Fedora soon, like in a matter of weeks.  I'm willing to assist in creating a patch for redhat-lsb if needed.
Comment 8 Xibo Ning 2012-07-25 00:39:26 EDT
Hi Tom, LSB is a api/abi standard, some software, for example, gooogle chrome browser need we support this standard. Please reference here:
http://en.wikipedia.org/wiki/Linux_Standard_Base
Comment 9 Tom Lane 2012-07-25 01:23:58 EDT
Perhaps I'm missing the point, but I see nothing in ISO 23360-1 or ISO 23360-2 that mandates libpng at all, let alone libpng 1.2 in particular.  You're going to need more evidence than this if you want me to not remove libpng-compat from the distribution.
Comment 10 Parag Nemade 2013-01-16 22:58:23 EST
what is remaining to be done here in this bug?
Comment 11 Tom Lane 2013-01-17 01:22:57 EST
Oh, I forgot this is still open.

After discussion elsewhere it was concluded that we do still need to ship libpng 1.2 for the time being (solely, IMO, for pro forma compliance with LSB, not because there's a *good* reason to ship it).  If you're referencing the library by soname then this is NOTABUG.  If you're referencing libpng-compat, it should be renamed to libpng12 in the Requires.
Comment 12 Ondrej Vasik 2013-05-22 14:32:48 EDT
libpng soname is referenced. Closing NOTABUG per Tom's comment.

Note You need to log in before you can comment on or make changes to this bug.