Bug 835789 - Fedora 17 on Dell E6420 laptop does not detect external dvi ports on docking station
Fedora 17 on Dell E6420 laptop does not detect external dvi ports on docking ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 02:44 EDT by Tero Hiekkalinna
Modified: 2012-11-30 19:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 03:07:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages & /var/log/Xorg.0.log & /var/log/Xorg.0.log (1.67 MB, text/plain)
2012-06-27 02:44 EDT, Tero Hiekkalinna
no flags Details

  None (edit)
Description Tero Hiekkalinna 2012-06-27 02:44:12 EDT
Created attachment 594694 [details]
/var/log/messages & /var/log/Xorg.0.log & /var/log/Xorg.0.log

Description of problem:

Fedora 17 on Dell E6420 laptop (Quadro NVS 4200M video card) does not detect external dvi ports on docking station. Only VGA port works.

Version-Release number of selected component (if applicable):

Epoch       : 1
Version     : 0.0.16
Release     : 35.20120306gitf5d1cd2.fc17

How reproducible:

Install fresh copy of Fedora 17 x86_64 into Dell E6420 laptop

Steps to Reproduce:
1. Install fresh copy of Fedora 17 x86_64 into Dell E6420 laptop
2. update system with yum (update date 26/6/2012) & shutdown
3. Put laptop to docking station (EURO2 Advanced)
3. Start Fedora
  
Actual results:

DVI ports (two of them) does not work on docking station (Dell and Samgsung LCD screen are connected to the ports), only VGA port in docking station works.

Expected results:

DVI ports should work and xrandr should list them.

Additional info:

xrandr lists:

LVDS2 connected 1600x900+0+0 (normal left inverted right x axis y axis) 310mm x 174mm
   1600x900       60.1*+   40.3  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA2 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0*+
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1280x800       59.8  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  

lspci -v output and VGA-sections:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 0493
        Flags: bus master, fast devsel, latency 0, IRQ 44
        Memory at e5400000 (64-bit, non-prefetchable) [size=4M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915

01:00.0 VGA compatible controller: nVidia Corporation GF108 [Quadro NVS 4200M] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 1493
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at e4000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at e0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Expansion ROM at e5000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nouveau
Comment 1 Ben Skeggs 2012-06-27 03:07:04 EDT
This is not a bug, but the unfortunate expected behaviour of a great deal of Optimus systems currently.  Your manufacturer has *not* wired up the external outputs to the Intel GPU in your laptop, only the NVIDIA GPU can drive them.

From the looks of your kernel log, Nouveau has managed to detect a display at some point (but it won't be used because X is using the intel card), and the NVIDIA BIOS tables indicate the NVIDIA GPU can actually drive the laptop panel too.  You may be in luck if you check the system bios setup for a way to disable Optimus mode, and use just the NVIDIA GPU.

If it doesn't, you're out of luck until some new xserver work lands that will allow proper support for multi-GPU systems.
Comment 2 Tero Hiekkalinna 2012-06-27 03:22:12 EDT
I just disabled Optimus from the BIOS and Dual DVI works great! Thank you so much for your help!
Comment 3 Éloi Rivard 2012-11-30 19:15:00 EST
Hi. I have the same issue with a Latitude E6520, and the same video card. Do you use the nouveau driver, or proprietary one ?

Note You need to log in before you can comment on or make changes to this bug.