Red Hat Bugzilla – Bug 83581
Glib 2.2 can't work with older libgnomeui
Last modified: 2007-04-18 12:50:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003
Description of problem:
After upgrading some packages, among them glib2, almost all Gnome-related
programs started to crash. Owen Taylor explained the background for this:
You need to upgrade your libgnomeui package. The somewhat detailed
explanation is that
- It's been illegal to create base class types like GObject, or tkWidget. But
it used to more or less do something.
- We enforced the restriction in GLib-2.2, which showed that libgnomeui was
doing g_object_new (GTK_TYPE_WIDGET, NULL); in one spot, which caused a
There oght to be attributes in the RPM:s to protect this from happening.
(Assuming no --force or similar, of course.)
Version-Release number of selected component (if applicable):
A "Conflicts: libgnomeui < 2.1.90" in glib2 looks like an appropriate thing to me.
There's acutally a Conflicts: libgnomeui <= 2.2.0