Bug 83581 - Glib 2.2 can't work with older libgnomeui
Glib 2.2 can't work with older libgnomeui
Product: Red Hat Linux
Classification: Retired
Component: glib2 (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
Depends On:
  Show dependency treegraph
Reported: 2003-02-05 14:40 EST by Göran Uddeborg
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-05-19 16:40:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2003-02-05 14:40:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After upgrading some packages, among them glib2, almost all Gnome-related
programs started to crash.  Owen Taylor explained the background for this:

   You need to upgrade your libgnomeui package. The somewhat detailed  
   explanation is that

   - It's been illegal to create base class types like GObject, or tkWidget. But 
     it used to more or less do something.

   - We enforced the restriction in GLib-2.2, which showed that libgnomeui was 
     doing g_object_new (GTK_TYPE_WIDGET, NULL); in one spot, which caused a 

There oght to be attributes in the RPM:s to protect this from happening. 
(Assuming no --force or similar, of course.)

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:

A "Conflicts: libgnomeui < 2.1.90" in glib2 looks like an appropriate thing to me.
Comment 1 Matthias Clasen 2004-05-19 16:40:23 EDT
There's acutally a Conflicts: libgnomeui <= 2.2.0

Note You need to log in before you can comment on or make changes to this bug.