Bug 835860 - FTBFS: failure in self checks
FTBFS: failure in self checks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: matio (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Nicolas Chauvet (kwizart)
Fedora Extras Quality Assurance
:
: 879048 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 06:27 EDT by Karsten Hopp
Modified: 2013-01-10 12:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-10 12:36:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-06-27 06:27:36 EDT
Description of problem:
matio-1.5.0-2.fc18 fails to build on PPC(64), it fails during the self checks:
...
Read MAT version 4 (Little Endian)
  1: Read 2d double-precision array                  FAILED (mat4_read.at:44)
  2: Read 2d double-precision complex array          FAILED (mat4_read.at:62)
  3: Read 2D character array                         FAILED (mat4_read.at:80)
Read MAT version 4 (Big Endian)
  4: Read 2d double-precision array                  FAILED (mat4_read_be.at:44)
  5: Read 2d double-precision complex array          FAILED (mat4_read_be.at:62)
  6: Read 2D character array                         FAILED (mat4_read_be.at:80)
...
ERROR: 428 tests were run,
6 failed unexpectedly.
264 tests were skipped.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##


Steps to Reproduce:
1. ppc-koji build --scratch f18 matio-1.5.0-2.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=599176


Expected results:


Additional info:
Comment 1 Nicolas Chauvet (kwizart) 2012-11-11 06:05:13 EST
Do you have a patch or reported the issue to upstream ?
Comment 2 Nicolas Chauvet (kwizart) 2012-11-21 17:54:00 EST
*** Bug 879048 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas Chauvet (kwizart) 2013-01-10 12:36:54 EST
This might be fixed by the Dan Horak
http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=125662
Closing to rawhide

Note You need to log in before you can comment on or make changes to this bug.