Bug 835861 - Graphics does not work without "nomodeset" on a AMD HD6670("turks") based machine. Ugly display with "nomodeset"
Graphics does not work without "nomodeset" on a AMD HD6670("turks") based mac...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 06:27 EDT by abckb
Modified: 2012-07-09 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-09 12:32:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abckb 2012-06-27 06:27:43 EDT
Description of problem:
After a fresh installation of Fedora 17(x86_64), the screen remains black, login window never appears. I have to poweroff by pressing the hardware button. I CAN login by disabling modesetting by appending "nomodeset" at kernel parameter list at boot menu. It lets me proceed with login but the graphics is ugly, no 2d/3d acceleration. I did "yum update" and it updated the latest kernel(3.4.3) and other packages like xorg, mesa etc. But the problem remains. But this time the screen is not black, its purple and it flickers constantly. Again login window appears only after I do "nomodeset".

Version-Release number of selected component (if applicable):
fedora-17 stock kernel. Problem persists even after doing "yum update".


How reproducible:
Install Fedora-17(x86_64) on a machine with:
AMD Athlon2 X4-640 + Gigabyte 880GM UD2H mainboard + AMD HD6670 graphics card.
Output of HD6670 is fed to Monitor using VGA cable.

Steps to Reproduce:
1.Do a fresh install of Fedora-17(x86_64) on a machine with above hardware.
2.
3.
  
Actual results:
Screen remains blank and black after boot. Login window never appears. Pressing "Ctrl + Alt + Backspace" makes the screen purple.

Expected results:
After booting login window should appear, and when I provide username and password and select session, KDE should start with 2d acceleration.


Additional info:
Comment 1 abckb 2012-07-05 06:43:14 EDT
I found a post in thinkdigit.com tech forum, where the guy who posted it is having similar hardware and is facing absolutely the same problem as mine, though with different distro. Please see the photo of his stuck desktop that the guy has posted: http://dl.dropbox.com/u/31237284/graphics-problem.JPG

^In my case Fedora was stuck(just a blank screen, sometimes it flickered) before the login screen was displayed. So I coul'd not even login.

BUT, login screen appears and it lets me login if I disable KMS by appending "nomodeset" at the kernel parameter.

Please let me know if you need any additional informations.
Comment 2 Jérôme Glisse 2012-07-05 10:20:12 EDT
Is it up to date f17, lot of fixes went in.
Comment 3 abckb 2012-07-08 03:11:20 EDT
Hi Jerome and all,
   Last night i did a full system update and thankfully the problem is gone. Now login screen appears and I get native resolution with acceleration. Maybe the latest xorg-x11-drv-ati has fixed it. But this does not explain why graphics worked so fine when booted from a live media and failed when installed on harddisk.
Comment 4 Jérôme Glisse 2012-07-09 12:32:41 EDT
World is full of strangeness

Note You need to log in before you can comment on or make changes to this bug.