Bug 835893 - cmirror does not support mirrored mirrorlogs
cmirror does not support mirrored mirrorlogs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2 (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 09:09 EDT by Axel Thimm
Modified: 2014-09-24 13:12 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 19:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 255723 None None None Never

  None (edit)
Description Axel Thimm 2012-06-27 09:09:13 EDT
Description of problem:
cmirror does not support mirrored mirrorlogs. This is a known issue, see bug #612221 comment 11:
"Mirrored log type for cluster mirrors will have to be deferred to a later release.  I will soon commit the patch that disallows this.  Reason from my patch:

Disallow mirrored logs in cluster mirrors.

The cluster log daemon (cmirrord) is not multi-threaded and
can handle only one request at a time.  When a log is stacked
on top of a mirror (which itself contains a 'core' log), it
creates a situation that cannot be solved without threading.

When the top level mirror issues a "resume", the log daemon
attempts to read from the log device to retrieve the log
state.  However, the log is a mirror which, before issuing
the read, attempts to determine the 'sync' status of the
region of the mirror which is to be read.  This sync status
request cannot be completed by the daemon because it is
blocked on a read I/O to the very mirror requesting the
sync status."

Mirrored mirrorlogs are required for a symmetrical host-based mirrored Storage setup.

See also  bug #746792, where this was recently discussed (but more on making lvcreate properly exit on such requests)

Version-Release number of selected component (if applicable):
cmirror-2.02.95-10.el6

How reproducible:
always

Steps to Reproduce:
1. lvcreate ... --mirrorlog mirrored ... on a clustered VG
2.
3.
  
Actual results:
The request is rejected due to cmirror not being able to handle it.

Expected results:
(clustered) mirrored mirrorlogs should be a feature of RHEL.

Additional info:
HA LVM will probably work with mirrored mirrorlogs, so for some applications this may be a viable workaround.
Comment 4 RHEL Product and Program Management 2012-07-30 19:06:13 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.