Bug 835895 - Data corruption during Windows guest installation with qcow2 + virtio drivers
Data corruption during Windows guest installation with qcow2 + virtio drivers
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virtio-win (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ronen Hod
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 09:19 EDT by Cleber Rosa
Modified: 2013-04-01 11:08 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-01 11:08:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Test #1 screenshot (37.31 KB, image/jpeg)
2012-06-27 09:19 EDT, Cleber Rosa
no flags Details
Test #1 video of windows installation (2.94 MB, video/ogg)
2012-06-27 09:20 EDT, Cleber Rosa
no flags Details
Test #2 screenshot of error (28.60 KB, image/jpeg)
2012-06-27 09:21 EDT, Cleber Rosa
no flags Details
Test #2 video of windows installation (2.09 MB, video/ogg)
2012-06-27 09:22 EDT, Cleber Rosa
no flags Details

  None (edit)
Description Cleber Rosa 2012-06-27 09:19:52 EDT
Created attachment 594771 [details]
Test #1 screenshot

Description of problem:

qemu fails to install a guest with Microsoft Windows 7 sp1 64 bits when using qcow2 storage and VirtIO drivers.

Version-Release number of selected component (if applicable):

qemu-kvm built from:
   - git repo url git://git.kernel.org/pub/scm/virt/kvm/qemu-kvm.git
   - initially found using commit 15ecf28f39e2b6fba359ed094770c8fa4ad8dc60 (tag qemu-kvm-1.1-rc3-63-g15ecf28)
   - still reproducible on commits as recent as b44d84dae10c1c835e2bb8e8ec4a308dea869c1e

kernel built from:
   - git repo url git://git.kernel.org/pub/scm/virt/kvm/kvm.git
   - commit f2ebd422f71cda9c791f76f85d2ca102ae34a1ed (tag v3.1-46053-gf2ebd42)

How reproducible:

Always when using qcow2 + VirtIO Drivers (but exact error on Windows installation varies).

Never when using raw+IDE, raw+VirtIO or qcow2+IDE.

Steps to Reproduce:
1. Build kernel from git
2. Reboot into new kernel
3. Build qemu(-kvm) from git
4. Start qemu to install windows
  
Actual results:

Windows guest does not complete the installation.

Expected results:

Windows guest should complete the installation.

Additional info:

qemu command line: qemu -name 'vm1' -nodefaults -monitor unix:'/tmp/monitor-humanmonitor1-20120606-073823-dQPO',server,nowait -qmp unix:'/tmp/monitor-qmpmonitor1-20120606-073823-dQPO',server,nowait -serial unix:'/tmp/serial-20120606-073823-dQPO',server,nowait -device ich9-usb-uhci1,id=usb1 -drive file='/tmp/kvm_autotest_root/images/win7-64-sp1.qcow2',index=0,if=virtio,cache=none -device virtio-net-pci,netdev=idzBJ5WD,mac='9a:1a:f7:8b:cc:26',id='iddFvSE3' -netdev tap,id=idzBJ5WD,fd=23 -m 2048 -smp 2 -drive file='/tmp/kvm_autotest_root/isos/windows/en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso',media=cdrom,index=1 -drive file='/tmp/kvm_autotest_root/isos/windows/winutils.iso',media=cdrom,index=2 -drive file='/tmp/kvm_autotest_root/isos/virtio-win.iso',media=cdrom,index=3 -fda '/tmp/kvm_autotest_root/images/win7-64-sp1/answer.vfd' -device usb-tablet,id=usb-tablet1,bus=usb1.0 -vnc :0 -vga std  -boot d
Comment 1 Cleber Rosa 2012-06-27 09:20:51 EDT
Created attachment 594772 [details]
Test #1 video of windows installation
Comment 2 Cleber Rosa 2012-06-27 09:21:23 EDT
Created attachment 594773 [details]
Test #2 screenshot of error
Comment 3 Cleber Rosa 2012-06-27 09:22:01 EDT
Created attachment 594775 [details]
Test #2 video of windows installation
Comment 9 Cole Robinson 2012-12-14 18:03:29 EST
Anyone have any more info on this? Cleber, can you still reproduce with something more modern? I'm curious if F18 bits can reproduce this.
Comment 10 Cleber Rosa 2012-12-17 11:16:19 EST
Cole,

We don't run regular tests using the Fedora packages, but using a base Fedora installation (currently F17) plus the upstream bits pulled from git.

Since it's been quite some time since the actual report, I'm inclined to believe that this is not relevant anymore. Still, I'll run a test on a F18 machine with the latest F18 bits.

I'll let you know about the outcome.

CR.
Comment 12 Mike Cao 2013-03-31 22:50:00 EDT
(In reply to comment #11)
> Mike, Cleber,
> 
> Can you try to reproduce it with the 6.4 virtio drivers?
> Could it be that Fedora with the latest drivers does not have this issue?
> 
> Thanks, Ronen.

Hi, Ronen

Sorry for the late response.
According to autotest results:
. rhel6 host
kernel-2.6.32-358.5.1.el6.x86_64
qemu-kvm-0.12.1.2-2.356.el6_4.2.x86_64
qemu-img-0.12.1.2-2.356.el6_4.2.x86_64
gpxe-roms-qemu-0.9.7-6.9.el6.noarch
seabios-0.6.1.2-26.el6.x86_64
sgabios-bin-0-0.3.20110621svn.el6.noarch
virtio-win-1.6.3.iso

repeat 50 times, can not reproduce it.

2. f18 host
kernel-3.6.10-4.fc18.x86_64
qemu-img-1.2.0-23.fc18.x86_64
qemu-kvm-1.2.0-23.fc18.x86_64
virtio-win-1.6.3.iso

repeat 100 times, can not reproduce it.
Comment 13 Cole Robinson 2013-04-01 11:08:05 EDT
Thanks Mike, closing as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.