Bug 835897 - agetn rpm - servie jon-agent start doesnt work for first time if before that jar jon agetn has been started via wrapper script
agetn rpm - servie jon-agent start doesnt work for first time if before that ...
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 837381
  Show dependency treegraph
 
Reported: 2012-06-27 09:26 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-03 10:22:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2012-06-27 09:26:51 EDT
Description of problem:
On old infrastructure - when jon server and agent are already installed using zip/jar and jon agetn has been started via wrapper script, 

Version-Release number of selected component (if applicable):
org.jboss.on-jboss-on-parent-3.1.0.GA-8

How reproducible:
always

Steps to Reproduce:
1. install jon server via zip
2. install jon agent  via jar
3. start jon server
4. start jon agent wia ./rhq-agent-wrapper.sh start
5. stop jon agent
6. install jon agent via rpm
7. call service jon-agent start 
  
Actual results:
agetn will not be started

Expected results:
jon aetn should be started

Additional info:
as soon as you start jon agent wia wrapper for rpm jon agent and stop it, "service jon-agent start" starts working well.
Comment 1 Mike Foley 2012-07-02 11:00:14 EDT
armine ... can you add logs?

stefan ... can you look at this?

bz triage  7/2 by foley, loleary, armine, asantos, zjin, viet
Comment 2 Mike Foley 2012-07-02 11:02:17 EDT
armine ... can you add logs?

stefan ... can you look at this?

bz triage  7/2 by foley, loleary, armine, asantos, zjin, viet
Comment 3 Zhengping Jin 2012-07-02 17:15:46 EDT
Just to exclude the following condition, and for comparing the test cases:
1. install server rpm 3.1.0 and agent jar separately, agent has been configured, so it knows where is the server.
2. start the agent via ./rhq-agent-wrapper.sh start
3. stop agent via ./rhq-agent-wrapper.sh stop
4. install agent rpm 3.1.0
5. run agent via service jon-agent start
Result: passed, could not reproduce the bug.
Comment 4 Armine Hovsepyan 2012-07-03 08:18:49 EDT
Hi all,

bug is not reproducable for me anymore. neither token, nor any other problem is being visible.

please mark it as worksForMe or Invalid, since it's not visible anymore.
Comment 5 Armine Hovsepyan 2012-07-03 10:22:46 EDT
invalid.

colsing for now, will be reopened if the case is reproduced.

Note You need to log in before you can comment on or make changes to this bug.