Bug 835904 - KDE PIM 4.9 beta 2 is missing Kolab Resource
KDE PIM 4.9 beta 2 is missing Kolab Resource
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdepim-runtime (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: libkolab
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 09:44 EDT by Georg Greve
Modified: 2012-06-28 19:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: kdepim-runtime-4.8.95-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 19:59:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Greve 2012-06-27 09:44:37 EDT
Description of problem:

KDE PIM 4.9 uses libkolab (and libkolabxml) for its kolab resource, which has become an optional  build dependency. Without the Kolab resource, Kontact does not pick up new groupware data nor can it add groupware objects against a Kolab server even though it won't actually warn about that.

So for all users of Kolab or Kolab like servers, libkolab is a very essential required build dependency.

Version-Release number of selected component (if applicable):
kdepim-runtime-4.8.90-2.fc17.x86_64

How reproducible:
Run Kontact, try to edit Kolab objects.

Steps to Reproduce:
1. Run Kontact
2. Add event
3. Watch how event does not appear on server
4. Seek kolab resource in akonadi, as it is missing
5. Discover it isn't there
  
Actual results:
No workee. ;)

Expected results:
Workee. ;)

Additional info:
Comment 1 Rex Dieter 2012-06-27 09:47:54 EDT
Once libkolab review is done ( bug #833853 ), it's built for rawhide, sure. :)
Comment 2 Rex Dieter 2012-06-28 19:59:47 EDT
Fixed in rawhide, kdepim-runtime-4.8.95-2.fc18

Note You need to log in before you can comment on or make changes to this bug.