Bug 835926 - unmet dependencies for latest CFSE
unmet dependencies for latest CFSE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity low (vote)
: Unspecified
: --
Assigned To: Jordan OMara
Og Maciel
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 10:42 EDT by Og Maciel
Modified: 2014-11-09 17:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:14:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2012-06-27 10:42:06 EDT
Description of problem:

TPS has reported that the following packages need to be provided by the CFSE repository:

Output from RPM Command:
error: Failed dependencies:
        jbossweb-servlet-2.5-api is needed by jboss-jacc-1.1-api-0:5.0.1-2.9.ep5.el6.noarch
        jaxrpc_1_1_api is needed by jboss-ejb-3.0-api-0:5.0.1-2.9.ep5.el6.noarch
        jaf_1_0_2_api is needed by jboss-jaxr-1.0-api-0:5.0.1-2.9.ep5.el6.noarch
Comment 2 James Laska 2012-06-27 10:56:59 EDT
Similar/same repoclosure problems exist in the current puddle.  

http://download.eng.bos.redhat.com/rel-eng/CloudForms/1.0.1/latest/logs/repoclosure-install.log

I believe this is caused by the candlepin packaging changes.  Jay Greguske (cc'd) mentioned the need to blacklist some of these packages from the puddle.

I'm not sure, but I suspect errata file list changes might be in order as well.
Comment 4 Og Maciel 2012-06-27 17:06:18 EDT
After some further investigation (thanks Eric!) it's been determined that the following packages should be removed from the errata:

* jboss-ejb-3.0-api
* jboss-jaxr-1.0-api
* grep jboss-jacc-1.1-api

On a CFSE 1.0.1 installation from latest puddle, these packages were nowhere to be found. Once those packages were removed and tps-rpmtest was re-run, the issue now seems to be Se related (see attached log).
Comment 7 Jay Greguske 2012-06-29 10:05:11 EDT
With the blacklist updated, these should be corrected. The blocked subpackages are:

jboss-jacc-1.1-api
jboss-ejb-3.0-api
jboss-jaxr-1.0-api
ant-apache-resolver
ant-commons-logging
quartz-oracle
Comment 10 Mike McCune 2012-10-24 10:14:18 EDT
this somehow missed the 1.0.z release but we are already done.

closing
Comment 11 Mike McCune 2013-08-16 14:15:30 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.