Bug 835949 - [rhevm] PosixFS: contending storm when adding additional host to pool
Summary: [rhevm] PosixFS: contending storm when adding additional host to pool
Status: CLOSED DUPLICATE of bug 835920
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine   
(Show other bugs)
Version: 3.1.0
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.1.0
Assignee: Laszlo Hornyak
QA Contact: Haim
URL:
Whiteboard: storage
Keywords: TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-27 15:45 UTC by Haim
Modified: 2016-02-10 16:36 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 05:49:30 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (125.93 KB, application/x-gzip)
2012-06-27 15:45 UTC, Haim
no flags Details

Description Haim 2012-06-27 15:45:58 UTC
Created attachment 594820 [details]
engine.log

Description of problem:

my case:

- 1 host in pool based on posix file-system storage domain
- pool is up and host is spm
- add additional host to pool
- backend send spmStop to host 1
- backend send spmStart to host 1

repeats the following in a loop (each time different host). 

no erros on VDS, the following log look suspicious:

2012-06-27 21:44:42,444 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.GetStoragePoolInfoVDSCommand] (QuartzScheduler_Worker-70) [1bc9b5e6] irsBroker::BuildStorageDynamicFromXmlRpcStruct::Failed building Storage dynamic, xmlRpcStruct = org.ovirt.engine.core.vdsbroker.xmlrpc.XmlRpcStruct@11b7121

Comment 2 Laszlo Hornyak 2012-07-09 14:36:24 UTC
Actual reason hiddin inside the bug:

java.lang.IllegalArgumentException: No enum const class org.ovirt.engine.core.common.businessentities.StorageType.SHAREDFS

Comment 3 Laszlo Hornyak 2012-07-09 17:17:26 UTC
http://gerrit.ovirt.org/6087

Comment 4 mkublin 2012-07-10 05:49:30 UTC
Doing what Laszlo proposed, closing all similar bugs as duplicates

*** This bug has been marked as a duplicate of bug 835920 ***


Note You need to log in before you can comment on or make changes to this bug.