Bug 835951 - ISE when descritpion or display-name has i18n characters on repo create
Summary: ISE when descritpion or display-name has i18n characters on repo create
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience
Version: Master
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-27 15:51 UTC by Preethi Thomas
Modified: 2015-02-28 21:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 21:49:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Pulp Redmine 338 None None None Never

Description Preethi Thomas 2012-06-27 15:51:03 UTC
Description of problem:
ISE when repo create is run with i18n characters for --display-name or description

Version-Release number of selected component (if applicable):

pulp-rpm-server-0.0.307-1.el6.noarch
pulp-rpm-admin-client-0.0.307-1.el6.noarch

How reproducible:


Steps to Reproduce:
1.  pulp-admin -u admin -p admin repo create --repo-id pulp1 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display-Brasília " --description "pulp repo desc" 
2.
3.
  
Actual results:
[root@preethi-el6-pulp ~]# pulp-admin -u admin -p admin repo create --repo-id pulp1 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display-Brasília " --description "pulp repo desc" 
An internal error occurred on the Pulp server. More information can be found in
the client log file ~/.pulp/admin.log.

[root@preethi-el6-pulp ~]# pulp-admin -u admin -p admin repo create --repo-id pulp2 --feed=http://repos.fedorapeople.org/repos/pulp/pulp/v1/stable/6Server/x86_64/ --display-name "pulp repo display" --description "pulp repo desc-Brasília" An internal error occurred on the Pulp server. More information can be found in
the client log file ~/.pulp/admin.log.


Expected results:


Additional info:

2012-06-27 11:36:07,928 16671:140082841384704: pulp.server.webservices.middleware.exception:ERROR: exception:62 Unhandled Exception
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in __call__
    return self.app(environ, start_response)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 38, in __call__
    return self.app(environ, start_response)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 278, in wsgi
    result = self.handle_with_processors()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in _handle_with_processors
    return process(self.processors)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
    return handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
    result = handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 27, in process
    return self.handle()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
    return self._delegate(fn, self.fvars, args)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 413, in _delegate
    return f()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 421, in <lambda>
    f = lambda: self._delegate_sub_application(pat, what)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 446, in _delegate_sub_application
    return app.handle_with_processors()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in _handle_with_processors
    return process(self.processors)
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 557, in processor
    return handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in process
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/web/application.py", line 572, in processor
    result = handler()
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 25, in <lambda>
    return p(lambda : process(processors))
  File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 27, in process
    return self.handle()
  File "/usr/lib/python2.6/site-packages/web/application.py", line 232, in handle
    return self._delegate(fn, self.fvars, args)
  File "/usr/lib/python2.6/site-packages/web/application.py", line 411, in _delegate
    return handle_class(cls)

Comment 1 Jason Connor 2012-06-28 16:52:42 UTC
It turns out that the display_name is arriving on the server as a 'latin-1' encoded string and mongo is barfing when we try to store it in the database as part of the arguments to the create_repo call_request.

Comment 2 Brian Bouterse 2015-02-28 21:49:28 UTC
Moved to https://pulp.plan.io/issues/338


Note You need to log in before you can comment on or make changes to this bug.