Bug 835971 - Error in sasl_client_start when installing packages to subscribed client via web ui
Error in sasl_client_start when installing packages to subscribed client via ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Og Maciel
: Regression, Triaged, ZStream
Depends On: 834697
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 13:22 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 834697
Environment:
Last Closed: 2012-07-10 03:25:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1062 normal SHIPPED_LIVE CloudForms System Engine 1.0.1 bug fix update 2012-07-10 07:18:51 EDT

  None (edit)
Comment 3 Jordan OMara 2012-06-28 14:05:18 EDT
Cherry picked for 1.0.1
Comment 5 Dan Macpherson 2012-07-01 21:51:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
An update to qpid-cpp-server enables QPID authentication as a default. The causes an error when installing packages to subscribed clients:

"AuthenticationFailure: Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more information (Credentials cache file '/tmp/krb5cc_48' not found)"

This update to System Engine explicitly disables QPID authentication in the configuration file. This removes the error and properly installs packages to subscribed clients.
Comment 6 Dan Macpherson 2012-07-01 21:54:22 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -2,4 +2,4 @@
 
 "AuthenticationFailure: Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more information (Credentials cache file '/tmp/krb5cc_48' not found)"
 
-This update to System Engine explicitly disables QPID authentication in the configuration file. This removes the error and properly installs packages to subscribed clients.+This update to System Engine explicitly disables QPID authentication in /etc/qpidd.conf. This removes the error and properly installs packages to subscribed clients.
Comment 7 Og Maciel 2012-07-01 23:32:07 EDT
Verified:

* candlepin-0.6.5-1.el6_2.noarch
* candlepin-tomcat6-0.6.5-1.el6_2.noarch
* katello-0.1.318-1.el6cf.noarch
* katello-all-0.1.318-1.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.7-1.el6_3.noarch
* katello-cli-0.1.112-1.el6cf.noarch
* katello-cli-common-0.1.112-1.el6cf.noarch
* katello-common-0.1.318-1.el6cf.noarch
* katello-configure-0.1.111-1.el6cf.noarch
* katello-glue-candlepin-0.1.318-1.el6cf.noarch
* katello-glue-foreman-0.1.318-1.el6cf.noarch
* katello-glue-pulp-0.1.318-1.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.10-1.el6.noarch
* pulp-1.0.4-1.el6.noarch
* pulp-common-1.0.4-1.el6.noarch
* pulp-selinux-server-1.0.4-1.el6.noarch
Comment 8 Og Maciel 2012-07-01 23:32:07 EDT
Deleted Technical Notes Contents.

Old Contents:
An update to qpid-cpp-server enables QPID authentication as a default. The causes an error when installing packages to subscribed clients:

"AuthenticationFailure: Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more information (Credentials cache file '/tmp/krb5cc_48' not found)"

This update to System Engine explicitly disables QPID authentication in /etc/qpidd.conf. This removes the error and properly installs packages to subscribed clients.
Comment 9 Og Maciel 2012-07-03 09:11:36 EDT
Seems that we had a "mid-air" collision and somehow I ended up with a comment related to tech notes. Please disregard that.
Comment 11 errata-xmlrpc 2012-07-10 03:25:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html

Note You need to log in before you can comment on or make changes to this bug.