Bug 835975 - SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from using the 'sys_admin' capabilities.
SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from usi...
Status: CLOSED DUPLICATE of bug 813870
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fd718a324bd6fbe36a44693aae6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 13:47 EDT by Moez Roy
Modified: 2014-01-23 12:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 05:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2012-06-27 13:47:57 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.3-1.fc17.x86_64
time:           Wed 27 Jun 2012 10:47:29 AM PDT

description:
:SELinux is preventing /usr/libexec/gstreamer-0.10/gst-plugin-scanner from using the 'sys_admin' capabilities.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that gst-plugin-scanner should have the sys_admin capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep gst-plugin-scan /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Objects                 [ capability ]
:Source                        gst-plugin-scan
:Source Path                   /usr/libexec/gstreamer-0.10/gst-plugin-scanner
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           gstreamer-0.10.36-1.fc17.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-132.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.3-1.fc17.x86_64 #1 SMP Mon Jun 18
:                              19:53:17 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 27 Jun 2012 10:47:10 AM PDT
:Last Seen                     Wed 27 Jun 2012 10:47:10 AM PDT
:Local ID                      a39754bd-3fc7-4a8b-b4d7-9819ec409a47
:
:Raw Audit Messages
:type=AVC msg=audit(1340819230.68:98): avc:  denied  { sys_admin } for  pid=2150 comm="gst-plugin-scan" capability=21  scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tclass=capability
:
:
:type=SYSCALL msg=audit(1340819230.68:98): arch=x86_64 syscall=ioctl success=yes exit=0 a0=7 a1=c020462b a2=7fff00afdbf0 a3=7fff00afd3a0 items=0 ppid=2149 pid=2150 auid=1001 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts1 ses=2 comm=gst-plugin-scan exe=/usr/libexec/gstreamer-0.10/gst-plugin-scanner subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: gst-plugin-scan,thumb_t,thumb_t,capability,sys_admin
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-28 05:47:29 EDT
You can dontaudit it using

# grep sys_admin /var/log/audit/audit.log | audit2allow -D -M mythumb
# semodule -i mythumb.pp

*** This bug has been marked as a duplicate of bug 813870 ***

Note You need to log in before you can comment on or make changes to this bug.