Bug 83603 - libXi not present on all platforms
Summary: libXi not present on all platforms
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: phoebe
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-06 05:49 UTC by Havoc Pennington
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-07 09:10:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2003-02-06 05:49:51 UTC
at-spi won't build because libXi is absent on x86_64, s390, at least.

Need to "make build" for at-spi after this is fixed.

I would expect this also results in GTK and Gimp building in crippled form, 
but maybe I'm just confused.

Comment 1 Owen Taylor 2003-02-06 15:25:03 UTC
Why the heck is libXi not present? There should be absolulety
nothing platform dependent on it.

If libXi isn't present, GTK+ will be built without XInput
support -- which means that graphics tablets won't work
fully.


Comment 2 Matt Wilson 2003-02-06 15:49:26 UTC
[msw@sid 4.2.99.901-20030203.1]$ rpm -qlp
s390x/XFree86-libs-4.2.99.901-20030203.1.s390x.rpm  | grep libXi
/usr/X11R6/lib64/libXi.so.6
/usr/X11R6/lib64/libXi.so.6.0
[msw@sid 4.2.99.901-20030203.1]$ rpm -qlp
x86_64/XFree86-libs-4.2.99.901-20030203.1.x86_64.rpm | grep libXi
/usr/X11R6/lib64/libXi.so.6
/usr/X11R6/lib64/libXi.so.6.0
[msw@sid 4.2.99.901-20030203.1]$ rpm -qlp
s390/XFree86-libs-4.2.99.901-20030203.1.s390.rpm | grep libXi
/usr/X11R6/lib/libXi.so.6
/usr/X11R6/lib/libXi.so.6.0



Comment 3 Mike A. Harris 2003-02-07 09:10:07 UTC
You might want to check the /usr/X11R6/%{lib} dir first.  ;o)

As Matt shows above, the libraries are definitely there.  The files are
all explicitly listed in the %files lists as well:

[mharris@devel XFree86-4.2.99.901]$ grep 'libXi\.' XFree86.spec
%{_x11libdir}/libXi.a
%{_x11libdir}/libXi.so
%{_x11libdir}/libXi.so.*

They are not ifarch'd, and if they do not exist in the RPM_BUILD_ROOT
after "make install" is done, when packaging time comes, rpm will
explode if these files are not found.

If your RPM packages somehow are missing these files, then it would
definitely have to be a bug in RPM itself.  ;o)


Note You need to log in before you can comment on or make changes to this bug.