Bug 836032 - python-BeautifulSoup-3.2.1-1.fc18 depends on Python 3
python-BeautifulSoup-3.2.1-1.fc18 depends on Python 3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-BeautifulSoup (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terje Røsten
Fedora Extras Quality Assurance
:
Depends On: 838675
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 18:44 EDT by Daniel Drake
Modified: 2012-08-09 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Drake 2012-06-27 18:44:54 EDT
This package depends on Python 3 even though it is the "Python 2 edition" of Beautiful Soup.

Can be seen at http://koji.fedoraproject.org/koji/rpminfo?rpmID=2972351 listing the requirements of python3-html5lib and python3-lxml.

Please remove these unnecessary dependencies from the python 2 part.
Comment 1 Terje Røsten 2012-07-09 14:47:48 EDT
This is due to inclusion of py3-bs4 subpackage in python-BeautifulSoup.

This will be fixed when python-beautifulsoup4 is imported.
Comment 2 Daniel Drake 2012-07-27 13:03:25 EDT
Thanks. Any news here? Looks like python-beautifulsoup4 is now in place, but the issue with python-BeautifulSoup is still present.
Comment 3 Terje Røsten 2012-07-28 05:21:50 EDT
python-bs4 is in testing, once in stable this issue will be fixed.
Comment 4 Fedora Update System 2012-07-31 13:16:23 EDT
python-BeautifulSoup-3.2.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-BeautifulSoup-3.2.1-3.fc17
Comment 5 Fedora Update System 2012-07-31 13:16:51 EDT
python-BeautifulSoup-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-BeautifulSoup-3.2.1-3.fc16
Comment 6 Fedora Update System 2012-08-01 14:15:37 EDT
Package python-BeautifulSoup-3.2.1-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-BeautifulSoup-3.2.1-3.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11321/python-BeautifulSoup-3.2.1-3.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-08-09 18:55:42 EDT
python-BeautifulSoup-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-08-09 19:29:51 EDT
python-BeautifulSoup-3.2.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.