Bug 836040 - RFE: need interactive network dialogue during kickstart
RFE: need interactive network dialogue during kickstart
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 19:50 EDT by joshua
Modified: 2012-06-28 09:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 03:01:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-06-27 19:50:41 EDT
Description of problem:

I see http://fedoraproject.org/wiki/Anaconda_Boot_Options#asknetwork and I am sad.  I have the need to kickstart machines with static IP addresses, but I don't need or want to implement a cgi-based web app to dynamically change what is an otherwise static ks.cfg file, just for one line that contacts the static IP.

Everything, and I mean everything, in my kickstart file is golden for all my machines... save the static IP address!

Please consider bring this back, or implementing this functionality another way!



Version-Release number of selected component (if applicable):

F17
Comment 1 Martin Sivák 2012-06-28 02:42:28 EDT
You should be able to configure the network using the boot prompt.

Take a look at:

ip=
ipv6=
gateway=
dns=
etc.

Is that enough for you?
Comment 2 Martin Sivák 2012-06-28 03:01:08 EDT
Interactive mode is not really the prefered plan for the anaconda dracut module so this bug will probably get closed in favour of the dracut's ip= boot option.

And I saw the second bug you filled so lets focus on it (#836039) first.
Comment 3 joshua 2012-06-28 09:42:35 EDT
The problem is that asking a user to edit a pxelinux entry to get their static IP address isn't exactly user friendly.

Note You need to log in before you can comment on or make changes to this bug.