Bug 83606 - /etc/fstab format doesn't work with latest kernels
/etc/fstab format doesn't work with latest kernels
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-06 03:02 EST by Frank Davis
Modified: 2007-04-18 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 16:50:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Davis 2003-02-06 03:02:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm in the process of building and testing 2.5.x kernels. as well as the latest
2.4.x kernels. It seems that RH 8.0's /etc/fstab isn't what the latest kernels
are looking for...

LABEL=/     /     ext3    defaults 1 2

doesn't work

/dev/hda3    /     ext3    defaults 1 2

boots..

I'm not sure if RH should change, or there's something in the kernel that should
be modified.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Build latest 2.4.x or 2.5.x kernel
2. Boot kernel and notice results
3.
    

Actual Results:  The system won't mount the filesystems as stated in the
/etc/fstab file.

Expected Results:  The systems should boot.

Additional info:
Comment 1 Bill Nottingham 2003-02-06 11:08:17 EST
Your initrd is probably not correct.

mkinitrd doesn't really support 2.5 kernels yet, as I recall.
Comment 2 Frank Davis 2003-02-06 11:17:44 EST
That might be true for 2.5.x (I will double check without booting 2.5.59 with
initrd), but it doesn't explain 2.4.21-pre4-ac2, since its the latest 2.4.x
kernel that should work well with mkinitrd. As I said, I will go back and test
both kernels without initrd.
Comment 3 Frank Davis 2003-02-10 16:09:10 EST
I tried my 2.5.59 kernel on a RH 7.3 system that has no labels on its
partitions. It worked. I have the latest RH 8.0 mkinitrd supplied with the
system (and labled partitions), and as reported, the same 2.5.59 will not work.
I noticed another bugzilla report for RH 7.3 that mentioned that a labeled root
partition works in RH 8.0 . I would differ with that statement. Please advise
further.
Comment 4 Erik Troan 2003-02-10 16:50:42 EST
Labels definitely work in Red Hat Linux 8 -- we use them by default in our
install. It very likely doesn't work with 2.5 however, and that probably won't
be addressed until 2.6 is available.

Note You need to log in before you can comment on or make changes to this bug.