Bug 836086 - yum update fails after upgrading Fedora 16 to 17 (x86_64)
yum update fails after upgrading Fedora 16 to 17 (x86_64)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 01:13 EDT by Doug Hutcheson
Modified: 2014-01-21 18:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 14:15:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of conflicts found by 'yum update' (16.67 KB, text/plain)
2012-06-28 01:13 EDT, Doug Hutcheson
no flags Details

  None (edit)
Description Doug Hutcheson 2012-06-28 01:13:23 EDT
Created attachment 594910 [details]
List of conflicts found by 'yum update'

Description of problem:
I ran 'yum update' after upgrading Fedora 16 to 17 and this message was reported:
Running Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
libcups.so.2 is needed by gtk2-2.24.10-2.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum

It also reported over 190 conflicts, but these seem to be across releases and architectures: for example it reports "alsa-lib-1.0.25-3.fc17.x86_64 is a duplicate with alsa-lib-1.0.25-1.fc16.i686". See the attached file for details.


Version-Release number of selected component (if applicable):


How reproducible:
run yum update


Steps to Reproduce:
run yum update
  
Actual results:
yum update failed

Expected results:
yum update should run to completion

Additional info:
Comment 1 Doug Hutcheson 2012-06-29 01:09:05 EDT
I solved the problem by running 'yum list [package name]' for each package where a conflict was reported. In most cases, the result showed the i686 version of the package was installed, but an update was available. I executed 'yum update [fully qualified package name]' (eg: 'yum update alsa-lib-1.0.25-1.fc17.i686') and the fc17 version was installed without further incident. I did this for all 195-odd reported conflicts and then successfully ran 'yum update', to install the remaining 1200-odd packages needing update from the versions on the fc17 installation .iso.

Fedora 17 is now happily humming away, apart from a problem with the annoying 'Oh, no! A problem has occurred ...' dialog the first time I try to log in. I am able to log in at the second attempt, so it must be something transitory.
Comment 2 James Antill 2012-06-29 14:15:01 EDT
 Those aren't "conflicts" they are pre-existing problems in the rpmdb, including:

mesa-dri-drivers-7.11.2-3.fc16.i686 has missing requires of mesa-dri-filesystem(x86-32)

...which is why yum didn't see it.

Note You need to log in before you can comment on or make changes to this bug.