This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836112 - Binary packages of php-xapian aren't legally redistributable
Binary packages of php-xapian aren't legally redistributable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xapian-bindings (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2012-06-28 03:05 EDT by Olly Betts
Modified: 2012-07-30 00:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 00:57:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olly Betts 2012-06-28 03:05:44 EDT
Fedora has started packaging Xapian's PHP bindings:

http://pkgs.fedoraproject.org/gitweb/?p=xapian-bindings.git;a=commit;h=d557cb7c4b97a5915f04db0c5dfc0a27c9b3b0c7

However, these currently combine code under GPLv2+ and the PHP 3.01 licences, which are incompatible - you can't legally distribute binary packages of the result:

http://trac.xapian.org/wiki/FAQ/PHP%20Bindings%20Package
Comment 1 Peter Robinson 2012-06-28 08:30:06 EDT
spot: can you review please
Comment 2 Adel Gadllah 2012-06-29 02:48:01 EDT
(In reply to comment #0)
> Fedora has started packaging Xapian's PHP bindings:
> 
> http://pkgs.fedoraproject.org/gitweb/?p=xapian-bindings.git;a=commit;
> h=d557cb7c4b97a5915f04db0c5dfc0a27c9b3b0c7
> 
> However, these currently combine code under GPLv2+ and the PHP 3.01
> licences, which are incompatible - you can't legally distribute binary
> packages of the result:
> 
> http://trac.xapian.org/wiki/FAQ/PHP%20Bindings%20Package

This is the reason why I didn't enable them in the past. See http://trac.xapian.org/ticket/191 for the upstream discussion.
Comment 3 Tom "spot" Callaway 2012-07-02 16:30:21 EDT
Yeah, you need to disable the PHP bindings because of this licensing issue. Sorry.
Comment 4 Fedora Update System 2012-07-16 17:43:00 EDT
xapian-core-1.2.12-1.fc17,xapian-bindings-1.2.12-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xapian-core-1.2.12-1.fc17,xapian-bindings-1.2.12-1.fc17
Comment 5 Fedora Update System 2012-07-19 05:05:44 EDT
Package xapian-core-1.2.12-1.fc17, xapian-bindings-1.2.12-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xapian-core-1.2.12-1.fc17 xapian-bindings-1.2.12-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10809/xapian-core-1.2.12-1.fc17,xapian-bindings-1.2.12-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-07-30 00:57:53 EDT
xapian-core-1.2.12-1.fc17, xapian-bindings-1.2.12-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.