Bug 836179 - NPE on deleting a scheduled operation
NPE on deleting a scheduled operation
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.4
x86_64 Windows
high Severity high (vote)
: ---
: JON 3.1.1
Assigned To: Jirka Kremser
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 05:41 EDT by Esa Tikka
Modified: 2012-07-12 08:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 08:11:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Esa Tikka 2012-06-28 05:41:48 EDT
Description of problem:
Trying to delete a scheduled operation causes "Failure in datasource while processing REMOVE request" due to a NPE. No way of deleting scheduled operations from the UI.


Version-Release number of selected component (if applicable):
Version: 4.4.0
Build Number: 516c434
GWT Version: 2.4.0
SmartGWT Version: 3.0


How reproducible:
Every time


Steps to Reproduce:
1.Create a scheduled operation (I used JBM JMS queue as the resource) which is either to be run later or to run repeatedly.
2.Select the operation in the Operations->Schedules view.
3.Click on Delete, confirm deletion.
  

Actual results:
"Failure in datasource while processing REMOVE request."
Stacktrace from error details:
java.lang.ClassCastException:null
--- STACK TRACE FOLLOWS ---
null
   at Unknown.java_lang_ClassCastException_ClassCastException__V(Unknown Source)
   at Unknown.com_google_gwt_lang_Cast_dynamicCast__Ljava_lang_Object_2ILjava_lang_Object_2(Unknown Source)
   at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_common_detail_operation_schedule_AbstractOperationScheduleDataSource_$copyValues__Lorg_rhq_enterprise_gui_coregui_client_inventory_common_detail_operation_schedule_AbstractOperationScheduleDataSource_2Lcom_smartgwt_client_data_Record_2Lorg_rhq_core_domain_operation_bean_OperationSchedule_2(Unknown Source)
   at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_operation_schedule_ResourceOperationScheduleDataSource_executeRemove__Lcom_smartgwt_client_data_Record_2Lcom_smartgwt_client_data_DSRequest_2Lcom_smartgwt_client_data_DSResponse_2V(Unknown Source)
   at Unknown.org_rhq_enterprise_gui_coregui_client_util_RPCDataSource_transformRequest__Lcom_smartgwt_client_data_DSRequest_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.<anonymous>(Unknown Source)
   at Unknown.com_google_gwt_core_client_impl_Impl_apply__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown Source)
   at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown Source)


Expected results:
Operation should be deleted.

Additional info:
Comment 1 Esa Tikka 2012-06-28 06:11:43 EDT
Verified reproducability with RHQ agent operation as well.
Comment 2 Heiko W. Rupp 2012-07-03 03:51:34 EDT
Jiri, could you please look into this?
Comment 3 Jirka Kremser 2012-07-03 09:14:17 EDT
Can you provide more info on how to reproduce the bug? I was trying it on 3 different types of a resource and everything worked well for me. Is the "JBM JMS queue" the only resource causing this bug?
Comment 4 Jirka Kremser 2012-07-03 12:44:52 EDT
I've tried to reproduce the bug also with EAP 4.3 (production profile) and with the resource JBM JMS Queue. Worked ok!
Comment 5 Esa Tikka 2012-07-03 13:24:18 EDT
I was able to produce those results with both the RHQ 4.4 agent operations and operations on JBoss EAP 4.3.0 JBM JMS Queue. The system has been very recently installed with a fresh DB. I am surprised that you didn't get the same results.

I'm currently having my summer vacation and am not really able to dig deeper into this for a while now. However, if there occurs a need for me to log on to my employers network during this time I'll see if I can refine the ticket/reproduction steps.

Is it possible that something in the JBoss JMX/JBM config could cause this? From the stack trace I'd guess that should not be the case? The RHQ installation itself is fairly default, basically only SMTP settings have been changed to match the network/environment.
Comment 6 Esa Tikka 2012-07-04 07:01:44 EDT
I checked it and for example this does produce the error for me:

1. Go to any RHQ agent -> Operations -> Schedules
2. Click New
3. Select operation: Get Current Date/Time
4. Schedule using:  Calendar
5. Select Now & Repeat
6. Run now and every: 1 minutes for 1 times
7. Click Schedule
8. Go back to Operations -> Schedules page
9. Click on the scheduled operation row
10. Click delete

I tested this today with two agents that are on different Windows platforms and both exhibited the same error and failed to delete the operation. I also have reproduced this using IE8 and SRWare Iron browser.
Comment 7 Jirka Kremser 2012-07-12 08:11:52 EDT
Tested also with windows platform in IE and it worked

Note You need to log in before you can comment on or make changes to this bug.