Bug 836203 - jenkins "It appears that your reverse proxy set up is broken."
jenkins "It appears that your reverse proxy set up is broken."
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Triaged
Depends On:
Blocks: 1192753
  Show dependency treegraph
 
Reported: 2012-06-28 06:56 EDT by Aleksandar Kostadinov
Modified: 2015-05-14 18:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksandar Kostadinov 2012-06-28 06:56:58 EDT
I see that error message when I created a new jenkins app. It links to a wiki page [1] with more details. Perhaps that can be fixed?


[1] https://wiki.jenkins-ci.org/display/JENKINS/Jenkins+says+my+reverse+proxy+setup+is+broken
Comment 1 Dan Mace 2012-07-03 11:00:16 EDT
Created a new Jenkins-enabled jbossas-7 app in dev (ami-9bcb67f2 - devenv_1870) with the following command:

rhc-create-app -a jbossapp -t jbossas-7 --enable-jenkins -p none

And had no issues with the resulting Jenkins instance. Please provide precise steps to reproduce in a dev environment.
Comment 2 Dan Mace 2012-07-03 11:04:42 EDT
Disregard comment 1, I see the error now in the "Manage Jenkins" page.
Comment 3 surya 2012-08-14 10:48:56 EDT
I am even facing this error.

I created a DIY application running Python 2.7, Django using uWsgi 1.2.4

So do a Jenkins Server as another app.

Now, whenever, I open jenkins/manage, I find the following error.

"It appears that your reverse proxy set up is broken"
Comment 4 Luke Meyer 2012-08-15 10:53:25 EDT
Experiencing this on my public instance. I created the Jenkins instance independently rather than as part of another app. Looking at the network traffic in Chrome, what looks to be happening is that from https://jenkins-sosiouxme.rhcloud.com/manage (note, httpS) the test query it is performing is 

http://jenkins-sosiouxme.rhcloud.com/administrativeMonitor/hudson.diagnosis.ReverseProxySetupMonitor/test-for-reverse-proxy-setup

... so, possibly the instance is confused about the scheme for self-reference. This might be specific to Jenkins. I'll spin up a dev instance and see if the same thing happens.
Comment 5 Paul Morie 2012-09-20 17:34:39 EDT
The problem was as Luke commented - the redirect from https url is to an http one.  Fix was to add a rule to httpd vhost configuration rewriting http urls to https.  

Pull request: https://github.com/openshift/crankcase/pull/515
Comment 6 Xiaoli Tian 2012-09-27 05:37:37 EDT
(In reply to comment #5)
> The problem was as Luke commented - the redirect from https url is to an
> http one.  Fix was to add a rule to httpd vhost configuration rewriting http
> urls to https.  
> 
> Pull request: https://github.com/openshift/crankcase/pull/515

Above pull request is merged, move it to ON_QA to verify.
Comment 7 Jianwei Hou 2012-09-28 06:35:31 EDT
Verified on devenv_2250

Steps:
1. Create a jenkins server app
2. Open jenkins webconsole -> Jekins -> Manage Jenkins

Result:
Error message is remove now.

Note You need to log in before you can comment on or make changes to this bug.