Bug 836240 - The buildroot does not retrieve the external repositories correctly
The buildroot does not retrieve the external repositories correctly
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 09:11 EDT by Pieter de Rijk
Modified: 2012-06-28 10:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 10:19:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file of building the build-root (44.80 KB, application/octet-stream)
2012-06-28 09:11 EDT, Pieter de Rijk
no flags Details

  None (edit)
Description Pieter de Rijk 2012-06-28 09:11:34 EDT
Created attachment 595012 [details]
log file of building the build-root

Description of problem:

The buildroot does not retrieve the external repositories correctly.

There is a pkgorigins.gz with a link to the original location.

yum does not put the values from pkgorigings.gz in the prefix of the fetch:

DEBUG util.py:258:    audit-libs-1.8-2.el5.x86_64: failed to retrieve audit-libs-1.8-2.el5.x86_64.rpm from build
DEBUG util.py:258:  error was [Errno 2] Local file does not exist: /CentOS/audit-libs-1.8-2.el5.x86_64.rpm
DEBUG util.py:258:    4:perl-5.8.8-38.el5.x86_64: failed to retrieve perl-5.8.8-38.el5.x86_64.rpm from build
DEBUG util.py:258:  error was [Errno 2] Local file does not exist: /CentOS/perl-5.8.8-38.el5.x86_64.rpm

Version-Release number of selected component (if applicable):

1.7.0-2.el5

How reproducible:

Steps to Reproduce:
1. install an own koji server
2. bootstrap with external repositories
3. submit a build
  
Actual results:

Failing build, due to problems by mock to set up a build-root.

Expected results:

Correct setup of the build-root and start building the package.

Additional info:

If I point yum.conf directly to the original base value, and then yum can find the packages correctly.

Some possible solutions:

1) Add the external-repos to the yum.conf in the build root
2) Ensure yum is able to work with pkgorigins.gz files in the repo-date

Maybe there are more options... but these came to my mind...
Comment 1 Mike McLean 2012-06-28 10:19:03 EDT
Yum does not know or care about pkgorigins.gz. This file is for koji's benefit. It is essentially log data generated when the external repo(s) are merged into koji's.

The standard repodata (e.g. primary.xml.gz) should have alternate base urls for each rpm that comes from an external repo.

Other folks (notably Fedora) are not having this issue. Judging from your logs, this is a very new koji setup. Most likely this is a configuration issue. External repo configuration can be tricky.

It would be better to discuss this on the mailing list rather than in bugzilla. Please move this discussion there:
https://admin.fedoraproject.org/mailman/listinfo/buildsys

The following data might help debug your issue
1) repo configuration
# koji list-external-repos
# koji list-external-repos --tag dist-intern-el5-build
2) data access information
- how is the failing builder accessing /mnt/koji?
- how is the failing builder accessing the external repo?
3) data from the repo in question
# zgrep pam-0.99.6.2-6.el5_5.2.x86_64.rpm pkgorigins.gz
# zgrep pam-0.99.6.2-6.el5_5.2.x86_64.rpm primary.xml.gz
4) log files from the createrepo tasks that created the repo in question

Again, let's please move this discussion to the mailing list. I am closing this bug for now at least.

Note You need to log in before you can comment on or make changes to this bug.