This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836275 - qemu-ga: change on fsfreeze semantics when compared to RHEL6
qemu-ga: change on fsfreeze semantics when compared to RHEL6
Status: CLOSED DUPLICATE of bug 831174
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: pre-dev-freeze
: 7.0
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks: 831387
  Show dependency treegraph
 
Reported: 2012-06-28 10:35 EDT by Luiz Capitulino
Modified: 2012-10-26 13:11 EDT (History)
10 users (show)

See Also:
Fixed In Version: 1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 09:51:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luiz Capitulino 2012-06-28 10:35:25 EDT
During the review process of the patches which updated qemu-ga to its latest upstream version (which is v1.1), it was identified some semantics changes of the file-system freeze process that may be undesirable or even cause regressions.

The changes are:

o qmp-guest-fsfreeze-freeze can be called even if the FS is already frozen (by qmp-guest-fsfreeze itself). Before, qmp-guest-fsfreeze couldn't be called twice in a row (a call to qmp-guest-fsfreeze-freeze had to match a call to qmp-guest-fsfreeze-thaw)

o qmp-guest-fsfreeze-thaw re-builds the FS list to be thawed every time it's called, this means that it will see file-system changes between freeze and thaw (ie. if a new FS "appears", it will be thawed). Before, qmp-guest-fsfreeze-thaw would only thaw the file-systems frozen by qmp-guest-fsfreeze-freeze

o qmp-guest-fsfreeze-thaw will thaw each file-system in a loop, meaning that it will thaw all file-system, regardless if they were thawed by another processes. Also, the loop makes it impossible to report errors. Before, qmp-guest-fsfreeze-thaw would thaw a file-system only once

All these issues have to be discussed upstream and if we decide to fix any of them the fixes have to be backported to 6.4.
Comment 1 Ademar Reis 2012-06-28 13:43:10 EDT
As far as RHEL is concerned, qemu-ga was tech-preview in RHEL6.3 and such a change in behavior is not a problem. But indeed, if they're "fixed" upstream, a backport to RHEL6.4 will be required.
Comment 2 juzhang 2012-07-18 23:40:29 EDT
QE will do viragent funcational in order to not bring regression after this issue is fixed
Comment 4 Paolo Bonzini 2012-10-25 09:31:49 EDT
Fixed in upstream commit 6a3c8c14c8467c5db3539f1b6e43e03318e5e21b.
Comment 5 Paolo Bonzini 2012-10-25 09:51:00 EDT

*** This bug has been marked as a duplicate of bug 831174 ***
Comment 6 Luiz Capitulino 2012-10-26 09:12:04 EDT
Paolo, I don't understand how moving the freeze state file solves this bz?

Actually, I also think this should be closed but for a different reason: it's probably too late to change those semantics again (unless they are buggy).
Comment 7 Paolo Bonzini 2012-10-26 10:52:57 EDT
The fix for the problems in comment 0 was to move the state file.  Upstream places the freeze state file in the same place as RHEL6, so there will be no change in fsfreeze semantics from RHEL6 to RHEL7.
Comment 8 Luiz Capitulino 2012-10-26 13:11:11 EDT
Makes sense.

Note You need to log in before you can comment on or make changes to this bug.