Bug 836286 - iptables init script calls /sbin/restorecon, but iptables rpm doesn't require the corresponding policycoreutils package
Summary: iptables init script calls /sbin/restorecon, but iptables rpm doesn't require...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iptables
Version: 6.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-28 15:03 UTC by Konstantin Volkov
Modified: 2013-02-21 08:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:43:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0332 normal SHIPPED_LIVE iptables bug fix and enhancement update 2013-02-20 20:54:21 UTC

Description Konstantin Volkov 2012-06-28 15:03:01 UTC
Description of problem:

iptables init script calls /sbin/restorecon, but iptables rpm doesn't require the corresponding policycoreutils package

Version-Release number of selected component (if applicable):

iptables-1.4.7-5.1.el6_2

How reproducible:

100%

Steps to Reproduce:

---
[root@noip ~]# /etc/init.d/iptables save
iptables: Saving firewall rules to /etc/sysconfig/iptables: /etc/init.d/iptables: line 268: restorecon: command not found
                                                           [FAILED]
[root@noip ~]# cat /etc/init.d/iptables | grep restorecon
                && restorecon $IPTABLES_DATA.save \
                && restorecon $IPTABLES_DATA \
[root@noip ~]# which restorecon
/usr/bin/which: no restorecon in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
[root@noip ~]# rpm -q iptables --requires | grep restorecon
[root@noip ~]# rpm -q iptables --requires | grep coreutils
---

On another RHEL6 node:

---
[root@hephaestus ~]# which restorecon
/sbin/restorecon
[root@hephaestus ~]# rpm -qf /sbin/restorecon
policycoreutils-2.0.83-19.21.el6_2.x86_64
---
  
Actual results:
/etc/init.d/iptables save fails

Expected results:
/etc/init.d/iptables save should work

Please add the policycoreutils to the iptables package requires

Comment 7 errata-xmlrpc 2013-02-21 08:43:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0332.html


Note You need to log in before you can comment on or make changes to this bug.