Bug 836297 - self check failure on PPC
self check failure on PPC
Status: CLOSED DUPLICATE of bug 835877
Product: Fedora
Classification: Fedora
Component: elfutils (Show other bugs)
17
powerpc Linux
high Severity high
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 11:48 EDT by Karsten Hopp
Modified: 2012-06-28 12:26 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 12:26:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2012-06-28 11:48:48 EDT
Description of problem:
elfutils-0.154-1.fc18 fails during the self checks on PPC:

PASS: run-typeiter.sh
PASS: run-readelf-d.sh
--- unstrip.out	2012-06-28 08:26:09.206820951 -0700
+++ -	2012-06-28 08:26:09.211736275 -0700
@@ -1,6 +1,6 @@
 0x8048000+0x2000 f1c600bc36cb91bf01f9a63a634ecb79aa4c3199@0x8048178 . - [exe]
 0xf77d6000+0x1000 676560b1b765cde9c2e53f134f4ee354ea894747@0xf77d6210 . - linux-gate.so.1
-0xf77b3000+0x9000 - /lib/librt.so.1 - librt.so.1
-0xf7603000+0x1b0000 - /lib/libc.so.6 - libc.so.6
-0xf75e9000+0x1a000 - /lib/libpthread.so.0 - libpthread.so.0
+0xf77b3000+0x9000 c6c5b5e35ab9589d4762ac85b4bd56b1b2720e37@0xf77b3164 /lib/librt.so.1 - librt.so.1
+0xf7603000+0x1b0000 0b9bf374699e141e5dfc14757ff42b8c2373b4de@0xf7603184 /lib/libc.so.6 - libc.so.6
+0xf75e9000+0x1a000 29a103420abe341e92072fb14274e250e4072148@0xf75e9164 /lib/libpthread.so.0 - libpthread.so.0
 0xf77d7000+0x21000 6d2cb32650054f1c176d01d48713a4a5e5e84c1a@0xf77d7124 /lib/ld-linux.so.2 - ld-linux.so.2
FAIL: run-unstrip-n.sh
PASS: run-low_high_pc.sh

Version-Release number of selected component (if applicable):
elfutils-0.154-1.fc18

How reproducible:
always

Steps to Reproduce:
1.ppc-koji build --scratch f18 elfutils-0.154-1.fc18.src.rpm
2.
3.
  
Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=599693

Expected results:


Additional info:
Comment 1 Petr Machata 2012-06-28 12:26:40 EDT

*** This bug has been marked as a duplicate of bug 835877 ***

Note You need to log in before you can comment on or make changes to this bug.