Bug 836329 - koji.ssl.SSLCommon.PlgHTTPSConnection() forces IPv4
koji.ssl.SSLCommon.PlgHTTPSConnection() forces IPv4
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-28 13:42 EDT by Alexey I. Froloff
Modified: 2013-07-31 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-31 19:47:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Quick hack to try AF_INET and AF_INET6 (1.05 KB, patch)
2012-06-28 13:42 EDT, Alexey I. Froloff
no flags Details | Diff

  None (edit)
Description Alexey I. Froloff 2012-06-28 13:42:48 EDT
Created attachment 595097 [details]
Quick hack to try AF_INET and AF_INET6

Description of problem:

socket.socket() is only called with family=socket.AF_INET, which prevents usage of IPv6 protocol.

Version-Release number of selected component (if applicable):

Comment 1 Alexey I. Froloff 2012-08-07 06:01:42 EDT
Is someone working on that?
Comment 2 Dan Williams 2012-08-10 13:34:05 EDT
I'm the original author of that bit of Plague code which Koji took over; patch looks fine to me...  I don't have any commit rights for Koji though since I'm long out of the infrastructure business.
Comment 3 Mike McLean 2012-08-10 22:45:22 EDT
Thanks for the patch Alexey, and thanks for looking Dan. I'll have a look next week.
Comment 4 Dennis Gilmore 2012-08-16 21:07:46 EDT
I suggest that socket.AF_INET6 be tried before socket.AF_INET just because thats the prefered way of doing things in the wild in that if there is a ipv6 address it will be tried first.
Comment 5 Alexey I. Froloff 2013-01-29 06:17:55 EST
Currently in F18 (koji-1.7.1-2.fc18.noarch) in this code socket.getaddrinfo() function is used, so it should work as expected.

Comment 6 Fedora End Of Life 2013-07-03 18:08:03 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2013-07-31 19:47:19 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.