Bug 836365 - RHEL 6.2, bnx2x driver / netxtreme2 package broken on NetXtreme II BCM57711 10-Gigabit PCIe
RHEL 6.2, bnx2x driver / netxtreme2 package broken on NetXtreme II BCM57711 1...
Status: CLOSED DUPLICATE of bug 836363
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.2
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Michal Schmidt
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 16:18 EDT by bmcnally
Modified: 2016-01-04 17:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 14:55:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bmcnally 2012-06-28 16:18:33 EDT
Description of problem:

RHEL 6.2 seems to have a regression in the bnx2x driver, or perhaps the problem was never fixed. The problem I'm having is described here:

https://access.redhat.com/knowledge/ja/node/47669

I'm using the following hardware:

Broadcom Corporation NetXtreme II BCM57711 10-Gigabit PCIe

When I attempt to insmod the bnx2x driver I get this in dmesg:

===
bnx2x: [bnx2x_leader_reset:9755(eth2)]Something bad had happen on engine 0! Aii!
bnx2x: [bnx2x_open:12067(eth2)]Recovery flow hasn't been properly completed yet. Try again later.
If you still see this message after a few retries then power cycle is required.
===

Version-Release number of selected component (if applicable):

RHEL 6.2, x86_64

How to reproduce:

1. Build system running RHEL 6.2 with one of these adapters.

2. Download the latest netxtrem2 package. I've tried both of these, the first from Redhat, the second directly from Broadcom:

netxtreme2-7.0.36-1.x86_64.rpm
netxtreme2-7.2.20-1.x86_64.rpm

3. rmmod any existing bnx2x driver, insmod the new one.

4. Run dmesg, see the error above. Notice that the NIC is unusable. ethtool shows that there is no link, ifconfig doesn't list the device as "UP."
Comment 2 Michal Schmidt 2012-07-02 14:55:50 EDT

*** This bug has been marked as a duplicate of bug 836363 ***
Comment 3 k8 2016-01-04 17:45:23 EST
I'm sorry, as a mere mortal I don't have access to this original bug 836363 - how can I get more details? 

two of my interfaces are failing like so on CentOS 6.x right now on a prod server in a faraway datacenter.. Can't even easily update linux/kernel as due to that I've lost internet connectivity because broadcom NIC doesn't initialize network. 

Interface works fine from Dell Lifecycle controller though.

Note You need to log in before you can comment on or make changes to this bug.